Zum Hauptinhalt wechseln

Die Neuauflage des Apple 13" MacBook Air von April 2014 wurde mit Dual-Core i5 und i7 Prozessoren aufgefrischt. Die Akkulaufzeit wurde etwas verbessert.

290 Fragen Alle anzeigen

IO board and display water damage?

Hi Guys,

First off thanks for the great forum, a lot of my questions have already been answered. But this one is a little trickier.

Some background, two days ago I rode home in the rain on my bike with my air in my backpack, when I got home this inside was a little wet. I tried to power on the laptop, and nothing. I let it dry out until last night and still nothing.

So I took apart the laptop and noticed a good amount of corrosion in the magsafe IO board. Additionally, I saw that there must've been a short in the IO board to logic board connector because (on the IO board side) there was a small burn mark that molded two leads together. Everything else looked pristine, no LSI indicators were gone on the logic board and couldn't see any corrosion what so ever.

As I happened to have another macbook air (early 2013) model laying around, I swapped out its Magsafe / IO board AND connector and she fired right up! However, even though the laptop booted, the display was completely messed up. The backlight was on but the display was translated with colors repeated / totally off.

So, in my head I thought maybe there was some connection between the IO board and the display, so I swapped back in the original mag safe (cleaned) and kept the 2012 IO/logic connector and I saw the same symptoms, boots up fine but the display is totally messed up.

I took a look at the LVDS connection on the completely other side of the board and it looked fine, really no water damage anywhere other than the IO board. So my question is this - is there any components in/around the IO board that could be affecting the display. Or, is there a display driver/logic board embedded in the display that would warrant checking?

Thanks for the help guys

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0

Kommentare:

Do you have a 820-xxxx number for your I/O board?

von

Einen Kommentar hinzufügen

1 Antwort

Connect to an external monitor. If you see the same thing it's the GPU/VGC logic board problem. If you don't it's something in the on-board display chain.

There is a board (connector) on the back of the display that may also have gotten wet/damp, but I don't know that you can disassemble that display screen from the top case without damaging it. The LVDS cable has to plug in to something.

If this answer is acceptable please remember to return and mark it.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

DavidG wird auf ewig dankbar sein.
Seitenaufrufe:

Letzten 24 Stunden: 0

Letzten 7 Tage: 0

Letzten 30 Tage: 0

Insgesamt: 566