Zum Hauptinhalt wechseln

Repariere deine Sachen

Recht auf Reparatur

Store

Ab Juli 2002. Modell K45SSWH oder K45SSEWH

22 Fragen Alle anzeigen

Why won't my mixer turn on?

I have my KitchenAid Classic Mixer plugged into the wall and when I turn it on to any of the speeds nothing happens. I've tried to unplug it and plug it back in but I cannot get it to turn on!

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 9
Einen Kommentar hinzufügen

Das Essential Toolkit

Die nützlichsten Werkzeuge in unserem kompaktesten Kit.

Jetzt kaufen

Das Essential Toolkit

Die nützlichsten Werkzeuge in unserem kompaktesten Kit.

Jetzt kaufen

2 Antworten

Hilfreichste Antwort

If your mixer isn't turning on, there could be several issues with it. First, check the circuit breaker in your home to make sure power is supplied to the mixer. Unplug your mixer and wait 15 seconds to plug it back in. If this does not work, there could be an issue with your phase board. See the guide on how to replace the KitchenAid mixer phase board.

War diese Antwort hilfreich?

Bewertung 3

Kommentare:

My mixer was squealing so I disassembled it. It was working fine other than making noise. I found metal shavings and a loose screw. I cleaned shavings, tightened the loose screw, lubricated and reassembled. Figuring this may be the fix to the noise. I plugged back in, turned it on and nothing. Power from outlet in working. When I turn on, it doesn't make any noise at all, like it's not getting power. I looked at electrical area and all connections seem fine.

von

Thank you Chris for help I really appreciate it

von

Einen Kommentar hinzufügen

My issues were that it 1st - only ran on one speed, then 2nd, wouldn't turn on at all. The problem (I think) ended up being two loose bolts in the back housing behind the switch controller. When I took off the back cover, they just fell out. I couldn't find any photos of what the assembly should have looked like, so it was trial and error testing. Once I put the loose bolts back on the “hidden” posts/screws on the far back metal plate and tightened them down (and undid all the other adjustments I tried to make first) it worked like a champ.

War diese Antwort hilfreich?

Bewertung 1

Kommentare:

I had the same problem but that didn’t resolve my issue

von

Einen Kommentar hinzufügen

Antwort hinzufügen

Chris Gonzales wird auf ewig dankbar sein.
Statistik anzeigen:

Letzten 24 Stunden: 1

Letzten 7 Tage: 14

Letzten 30 Tage: 80

Insgesamt: 7,270