Zum Hauptinhalt wechseln

Mid 2010 Modell A1278 / 2,4 oder 2,66 GHz Core 2 Duo Prozessor

795 Fragen Alle anzeigen

Runs from Battery but not charger

I've been given a dead Mid 2010 13" Macbook Pro because it was aparantly completely dead. When I connect the charger, the led glows very faintly green but it won't turn on.

I put a charged battery from my working macbook in it, and it turned on and worked fine - except it wouldn't detect the magsafe charger.

I then swapped the DC-in board with my working macbook but the problem remains.

So I've tried two chargers, two batteries and two DC-in boards all with the same symptoms - it works fine on the battery but not from the charger. I guess there's a fault on the logic board somewhere...

Can anyone suggest any common faults or where to start looking on the logic board for issues?

Thanks.

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung -1
Einen Kommentar hinzufügen

2 Antworten

Hilfreichste Antwort

The

DC in boards should be the same part numbers... you can look for "burned" spots or corrosion spots on the logic board (don't forget to look underneath).

The corrosion can be cleaned, the burned spots may indicate blown components... they are very hard to replace (soldering logic boards requires special skill and materials).

If the DC boards did match you might clean it (so further corrosion does not damage the machine) and use it as is, buy a replacement logic board or part out the machine.

Remember to return and mark accepted the answer that best solves your problem.

Good luck,

N

War diese Antwort hilfreich?

Bewertung 2

1 Kommentar:

Thanks for the responce. Yes, the dc board I replaced was the same part number.

I repair mobile phones down to component level for a living, so have access to all testing/rework equipment required. I'm currently attempting to trace the electrical path from the dc connector to find the fault, but any common faults or issues would be appreciated.

Thanks, Mike.

von

Einen Kommentar hinzufügen

See this thread: http://forums.macrumors.com/showthread.p...

There are many things to try, including checking the voltages at the DC in board and fuse location in the logic board for incoming power from the magsafe adapter. Also make sure thgat the magsafe pins are not stuck in the depressed position or dirty.

War diese Antwort hilfreich?

Bewertung 1
Einen Kommentar hinzufügen

Antwort hinzufügen

Mike Wynne wird auf ewig dankbar sein.
Seitenaufrufe:

Letzte 24 Stunden: 0

Letzte 7 Tage: 0

Letzte 30 Tage: 17

Insgesamt: 1,426