Zum Hauptinhalt wechseln

Veröffentlicht am 24. Oktober 2011 / 2.2, 2.4, oder 2.5 GHz Quad-Core Intel Core i7 Prozessor

353 Fragen Alle anzeigen

Weird audio problems with MacBook

A while ago I thought I blew up the audio chip in my macbook as I put too much signal through it. After I did that, the macbook shut down and when I booted it back up, it had no audio. The speakers didnt work, 3.5mm jack didnt work and when I went into the audio settings, there was no devices shown.

Recently I installed windows with the same result with the audio.

But when I turned it on and went into windows, the youtube video I had up last night was playing through my speakers. But when I went to try an audio test, they quit again.

I checked the Microphone input for the built in mic and it shows full bars, telling me its always picking up sound, which it is not.

The speakers also make a very quiet popping sound, only hearable when right up next to them, It doesnt change when volume is changed.

The other day, there was a red light shining or blinking (I dont remember) from out of the audio jack when it was closed and charging. Not sure if its related at all but I thought I would mention it.

If anyone knows what the heck is going on, your help would be much appreciated.

If there is any more info you need to know or any questions, Please ask!

Thanks!

Update 9/2/18

@mayer Heres the results from coconut battery

Block Image

Block Image

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Punktzahl 0

Kommentare:

Have you tried booting up on an external drive which has a fresh copy of macOS installed?

von

No. But how would that change anything?

von

The idea here is to remove OS level issues.

von

Ok I'll have to try that when I get home in a week. Anything I can try in the meantime?

von

@danj for some reason, when i booted it up today, it chimed which it has not done since I blew the chip. And when i went into windows, the sound worked for a little bit but stopped shortly after. I'm not sure what's going on. But it's very strange

von

9 Weitere Kommentare anzeigen

Einen Kommentar hinzufügen

MacBook Akku Fix Kits

Ab $69.99

Buy Now

MacBook Akku Fix Kits

Ab $69.99

Buy Now

2 Antworten

Hilfreichste Antwort

The red light from the audio port might mean the little switch inside is jammed and needs to be cleaned to get back in place. Some electric contacts spray cleaner with a toothpick might help in getting it back into place. I’d give a try at that first.

War diese Antwort hilfreich?

Punktzahl 2

Kommentare:

Thanks. I'll try that. But it only did that that one time, but I haven't seen it since

von

Run an audio jack in and out of it a few times.

von

Ok. @mayer but I'm not sure that's the problem. As audio works for a short time (less than a minute) and then doesnt work again unless I restart it. I'm probably wrong but it would probably not work at all, or work intermittently if that was the case

von

If you are getting a red light in the audio out port, the computer thinks it is outputting to an external speaker.

von

@mayer I tried that but no changes also, the light was only that one time, I haven't seen it since

von

Einen Kommentar hinzufügen

Go to “about this Mac > System report > Audio

see what is listed as the “Default System Output Device”

UPDATE

Sounds like your sound flower driver may be the issue.

Go under the Apple icon to System Preferences >

Sound >

Select the Internal Speakers

Test with the Output Volume bar.

UPDATE 9/1/18

how to remove soundflower from a mac

To uninstall it, please follow the steps below:

  1. Please go to Finder-> /System/Library/Extensions.
  2. Find Soundflower.kext.
  3. Remove it, then reboot your Mac.
  4. Reboot [seriously!] - This part is important! To ensure that the driver is unloaded correctly, you do need to reboot. Failing to do this part can result in update / installation / general weirdness (tm).
  5. Soundflower plug-in will be fully removed from your Mac.



War diese Antwort hilfreich?

Punktzahl 1

Kommentare:

@mayer it says that soundflower 2ch and 64ch is default. I installed it a while ago for something but haven't had any problems since that day. It also doesnt explain why it works for a short time, and why it didnt even show any audio devices for the longest time besides the soundflower ones.

von

@mayer already tried. That's what's selected. When it works, then it stops, even with that selected

von

Get rid of sound flower, then re-set it again.

von

How about trying setting up a new user account ?

von

@mayer I tried but it didnt go away. Its not in my launchpad but it didnt go away.

von

14 Weitere Kommentare anzeigen

Einen Kommentar hinzufügen

Antwort hinzufügen

Cameron wird auf ewig dankbar sein.
Statistik anzeigen:

Letzte 24 Stunden: 0

Letzte 7 Tage: 3

Letzte 30 Tage: 17

Insgesamt: 303