Zum Hauptinhalt wechseln

Repariere deine Sachen

Recht auf Reparatur

Store

Veröffentlicht am 16. September 2016. Modelbezeichnung 1660, 1778. Verfügbar in den Versionen: GSM oder CDMA / 32, 128 oder 256GB / Rosé Gold, Gold, Silber, mattschwarz oder hochglanz schwarz

1797 Fragen Alle anzeigen

iPhone 7 not charging, already replaced both Tigris and Tristar chips

Hi guys, I have an iPhone 7 here. The customer shorted the motherboard while cleaning the charging port. The phone was totally dead when he gave me the phone. Based on what the customer described, I believe the charging system on motherboard must be shorted. I removed both the Tigris and Tristar chips, the phone was able to turn on properly. I knew my judgement was correct. Then I installed a new Tigris and a new Tristar chip (610A3B). However, the phone was still not charging. I tried a known working charging flex, same result, the phone was not charging. When put the phone on charge, the phone recognised the USB lead (as it turned on properly), but no charging symbol on the phone.

Upon further testing, I found 5v arrived properly at Tigris, but 5v on Tristar is missing. I guess the Tristar regulator Q4001 was damaged as well, so I replaced the Q4001. Now 5v detected on Tristar chip. When put it on charge, the phone recognised the usb lead, and charging symbol appeared. To my surprise, however, although the phone showed charging, it’s actually not charging at all. Zero amps getting into the phone.

I did the Tristar twice, same result. I wonder, apart from the Tristar, is there anything else I can check?

Update: I also replaced the Q2101 with a new one, which is responsible for the communication between the Tigris and the battery, made no difference. The phone has 5v on both Tigris and Tristar, computer recognises it, it can connect to iTunes, the voltage of the components around the Tristar and Tigris are all correct, but the phone just wouldn’t charge. :(

I guess it’s the CPU or big PMIC. :(

Beantwortet! View the answer Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0

Kommentare:

Try testing with another charging port, it's possible that part still has gone bad.

von

Already tried that. There’s no problem with the charging port , as it works fine on another phone. It’s the motherboard issue.

von

Einen Kommentar hinzufügen

SPAR DIR DAS UPGRADE

Mach dein iPhone so gut wie neu mit unseren Fix Kits.

Jetzt entdecken

SPAR DIR DAS UPGRADE

Mach dein iPhone so gut wie neu mit unseren Fix Kits.

Jetzt entdecken

3 Antworten

Gewählte Lösung

It’s pretty rare for the PMIC to go bad. At this point, your phone is suffering from “fake charging” and that is typically a Tristar issue. Even though you have tried a few to date, it is possible you got a bad batch.

However, let’s take a step back. The problem occurred when the client tried cleaning out the charge port. They probably shorted some pins inside the port and that caused damage on the logic board. So I would check the following pins to see if there are any issues.

Block Image

These are fed directly by the charge port and I would be concerned that one of the traces may have been damaged. Start by probing in diode mode with the Tristar in place. There are test points for these or you can go on the dock connector. If the readings are weird, then remove Tristar and test for continuity between the dock connector and the pads.

If that looks good, then go to the Tigris circuit and check how TIGRIS_ACTIVE_DIODE is behaving by measuring the voltage. When a charger is plugged in, it should read HIGH (~VDD_MAIN) and when the charger is disconnected, it should read LOW (0V). Finally, check C2105. If the Tigris circuit is working properly in charge mode, pin 1 of the capacitor should have ~2X VDD_MAIN (~9V). that tells you the switcher is working properly.

Block Image

War diese Antwort hilfreich?

Bewertung 2

Kommentare:

Hi Minho, it’s me again. :). I checked C2105, only 1x VDD_main of voltage detected (4.25V). Does it mean the Tigris is not working properly? The thing is, I already did the tigris 3 times, tried different Tigris chips. The results are all the same.

von

Check to see if C2105 is shorted internally (not to ground); it shouldn't be.

von

I just checked it, C2015 is not internally shorted. Both pins are not grounded.

von

What is TIGRIS_ACTIVE_DIODE reading?

If you look at the circuit, C2105 is in a closed loop with only Trinity (coil) and Tigris (and a few bypass/decoupling caps). If the circuit understands it needs to charge the battery, then TIGRIS_ACTIVE_DIODE should go HIGH and pin 1 of C21065 should be double the VDD_MAIN.

von

I just tested it, no, TIGRIS_ACTIVE_DIODE didn’t go high, only 1xVDD_Main of voltage detected (4.25V) on TIGRIS_ACTIVE_DIODE .

von

4 weitere Kommentare anzeigen

Einen Kommentar hinzufügen

Hey there! So you’ve covered pretty much every base possible with the Tigris and Tristar replacement and ensuring you have a good lightning charging port. The only thing I didn’t see you mention (and I’m sure you have already) was trying to swap out the battery. If you haven’t done this yet go ahead and try that out but if so let me know and I will continue to find another solution for you

I thought about it some more. I would test the battery connection on the board:

  • Turn the DMM to voltage (V-DC) with a 20 unit scale.
  • Using the DMM (Multimeter) set the black probe on a ground location such as the SIM tray and place the red probe on the left-most battery terminal of the J connection on the board.

also was there any traces of the ground pad melting or too much heat coming from under the Tigris?

War diese Antwort hilfreich?

Bewertung 1

Kommentare:

Hi, thanks. Yes, I already tried a good battery. Replacing with a known working battery, a known working charging flex are things we repair technicians usually do in the 1st place when coming with charging issues like this. :)

von

Yes I did tested the battery connector at the 1st place. No voltage detected on battery connector when putting the phone to charge. It seems the communication is lost somewhere between the Tigris and the battery. I already replaced Q2101, made no difference. Both Tigris and Tristar chips are in normal temperature.

von

Einen Kommentar hinzufügen

I just had the same problem, for me the fix was to replace M2800, you can check the cap C2105 in my case the voltage was lower than 8v, also I check the cap in diode mode and the reading was off from a working circuit. The fix was to replace M2800. On another board I made a short reading C2105 and there was a smoke on M2800. So be very careful. Hope it helps someone.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

phonestore.uk wird auf ewig dankbar sein.
Statistik anzeigen:

Letzten 24 Stunden: 15

Letzten 7 Tage: 35

Letzten 30 Tage: 146

Insgesamt: 2,150