iMac A1418 late 2013 - no backlight, display ok, backlight circuit

Hi all,

as I went through several threads on ifixit and none of them covered my issue I hope someone might be able to help me with the following issue of an iMac A1418 late2013.

To make things short, the iMac works perfectly fine except of the backlight. All 4 status LEDs light up, the machine works flawless with an external monitor. So I narrowed down the issue to the logicboard/ backlight circuit, where I found a capacitor to be missing (I thought this should be it already - but no…)

Block Image

The display itself is fine as tested with another board.

After replacing the missing capacitor from a donor board, the backlight remained faulty. I was checking the FB8108 as recommended by another thread and it indeed was having a quiet high impedance 80kohms (referece board showed 0.4/continuity). Moreover Q8102 showed 9V instead of 12V which has been healed by replacing FB8108.

Although I think the solution cannot be too far from here, currently I am clue less where to look next for the culptit.

Any advice will be highly appreciated.

Cheers!

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 1

Kommentare:

I'm having a somewhat similar situation, with the same a1418 model.

One difference is that I do get the full 12V before Q8102, but I don't get it to come out on its output, because it's not being turned on by the BKLT_SHUTDOWN signal.

I doubt Q8102 is blown, but this could be checked by forcing its gate to turn it on, however, having zero info on the LP8561 driver, I'm not certain it will withstand this kind of treatment.

I do have all 4 diag LEDs turned on, so logically the backlight driver should not be shutting down the power to the screen, and so the mosfet Q8102 should get turned on by it. But it's not, so what else could cause a backlight shutdown, even though the 4th diag LED says it wants to turn power on to it?...

von

Einen Kommentar hinzufügen