Replaced Battery, System will not turn on.

I replaced the battery in my friends MacBook Pro Retina 2012 using the part and guide here on iFixit. After double checking my work I reinstalled the bottom plate, plugged in the mag safe charger (light was green then amber) and turned it on. I then turned my head to pull up the battery calibration procedure (maybe 30 seconds) and when I looked back the MacBook was off.


I pushed the power button, nothing.

I reset the SMC, the MacSafe charger flips from Green to Amber, but system will not power on.

I disassembled, rechecking for any loose wires, tripple checking the magsafe connector. Also ran a continuity check with my multimeter through the magsafe pcb through the connector pins (fine).

I tried unplugging the battery and starting with just the magsafe connector. No change.

I reassembled and let charge for ~12 hours. No Change.


I’m not sure what else to try. I don’t want to declare it dead as I am getting some feedback from SMC resets, but I’ve run out of ideas.


given that the system initially started, is it possible that the iFixit battery killed my system board?


Thanks for any help or idea’s you can give me.

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0

Kommentare:

Update 1: I pulled the bottom plate off and pried the trackpad connector off of the system board and immediately the system started and completely booted.

While I am very relieved that system functions i have the following issues/questions.

1. crazy to me that a trackpad will prevent a mac from booting. does anyone have a backstory?

2. the keyboard doesn't work either, the cable is still attached.

3. fans are spinning like crazy, but I assume that's because the trackpad is disconnected?

I've already tried resetting the SMC and PRAM to resolve these new issues.

More info as I get it.

von

Update 2: Turns out, the trackpad ribbon cable has a temp sensor built into it as well, and I managed to tear said cable (be careful!). ordered a new trackpad/cable combo from iFixit and installed. Some improvement. System Fans are normal, keyboard works fine, but the trackpad does not work still.

Tried;

1. Reseting SMC and PRAM - No improvement

2. using both trackpads (original and new from combo) - No Improvement.

3. Apply system updates (long shot) - No Improvement

4. Tried to run system diagnostics, diagnostics failed to load altogether. But TrackPad didn't respond while within the screen.

5. Ensured ribbon cable is affixed to system board

I've ordered another cable from Amazon as hail mary.

von

Einen Kommentar hinzufügen