Zum Hauptinhalt wechseln

Modell A1311 / Mitte 2010 / 3,06 & 3,2 GHz Core i3 oder 3,6 GHz Core i5 Prozessor

343 Fragen Alle anzeigen

iMac Mid-2010 21.5” No Chime Fans Spin 2 Diagnostic LEDs

What the title says. After nearly a decade of use, my mid-2010 21.5” iMac won’t boot into Mac OS and has no chime. However, the fans spin (normal speed first, at full speed after 1 minute) and I get 2 diagnostic leds. I tried reseting the SMC and the PRAM but it’s possible that the keyboard is not even powered (it’s hard to say). I disassembled the machine, cleaned out the dust, and replaced the logic board battery (waited 15 seconds with the battery removed). Does anyone have any advice for me?

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 1
Einen Kommentar hinzufügen

1 Antwort

With the disconnected display SMC will ramp up the fans speed so that is expected.

For reference here's the location and what the onboard Diagnostic LED's mean

Block Image

Here's a breakdown of the onboard diagnostic LED's:

LED 1 - Indicates that the trickle voltage from the power supply is detected by the main logic board. This LED will remain ON while the iMac is connected to the AC power. The LED will remain on even when the computer has been shut down or put to sleep. The LED will turn off only if the AC power is disconnected or the power supply is faulty.

LED 2 - Indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

LED 3 - Indicates that the computer and the video card are communicating. This LED will be ON when the computer is communicating properly with the video card. If LEDs 1 and 2 are ON and you heard the startup sound, but LED 3 is OFF, then the video card might be installed incorrectly or need replacement.

LED 4 - Indicates that the computer and the LCD display panel are communicating. This LED will be ON when the computer is turned on and video signal is being generated. If the LED is ON and there is no image on the LCD display panel, the LCD display panel or inverter might be installed incorrectly or need replacement.

So carefully reconnect the display (don't pull on the cable as it will damage the socket) I use a cable extension to make this easier.

If you only see the first two LED's lit then your GPU board needs to be replaced.

War diese Antwort hilfreich?

Bewertung 0

2 Kommentare:

Thank you! Do you know if I expect to hear a chime with the internal display disconnected? It feels like I’m back to where I started because I didn’t hear a chime before or after I disassembled the computer.

Also, the guide says for LED #3, “If LEDs 1 and 2 are ON and you heard the startup sound, but LED 3 is OFF, then the video card might be installed incorrectly or need replacement.” The thing is, I don’t hear the start chime. Could the video card still be the problem? Thank you 🙏!

von

@bootcamp004 - At it turns out Apple altered things! I think it was Snow Lion where they altered the firmware to turn off the startup bong as people didn't like it going off in an office environment. Apple then reversed things! Re-enabling it! Some folks also figured out how to set the firmware to either enable or disable the bong. So while the guide implies it I discount it as you never know which way its set!

von

Einen Kommentar hinzufügen

Antwort hinzufügen

Mason wird auf ewig dankbar sein.
Seitenaufrufe:

Letzte 24 Stunden: 0

Letzte 7 Tage: 10

Letzte 30 Tage: 34

Insgesamt: 338