Zum Hauptinhalt wechseln

Repariere deine Sachen

Recht auf Reparatur

Store

Hilfe

Aktuelle Version von: oldturkey03 (Bewertungsdetails) ,

Titel:

White screen, after replacing glass?

Text:

So i tried to repair my glass/digitizer and everything was fine until i saw the screen itself was defective since the replacement glass was not responding.

Me wanting to put back the old glass (it only had 1 crack) accidently pulled too hard on the suctioncup on the screen and ripped out the whole screen from all it's connectors on the motherboard. Luckily nothing was damaged from what i can see on the 1/2/3 wires, but now connector 3 has become loose in the sense that i can put it's wire in it and close it with the lock but i still comes out relatively easy, so i don't know if thats it.

After i switched those screens and connected everything i've gotten a white screen. (The sound still works though everything does actually except the screen itself)

I've read that i had to try and push on connector 1, straighten out the wires and clean them, but none of those things worked out.

I'm thinking it might be one of the connectors or the lcd itself might be the problem.

I hope you guys can help me with this though.

Thanks in advance.

Gerät:

iPhone 3GS

Status:

open

Akzeptierte Antwort:

120100

Ursprünglicher Beitrag von: Hamoudi ,

Titel:

White screen, after replacing glass?

Text:

So i tried to repair my glass/digitizer and everything was fine until i saw the screen itself was defective since the replacement glass was not responding.

Me wanting to put back the old glass (it only had 1 crack) accidently pulled too hard on the suctioncup on the screen and ripped out the whole screen from all it's connectors on the motherboard. Luckily nothing was damaged from what i can see on the 1/2/3 wires, but now connector 3 has become loose in the sense that i can put it's wire in it and close it with the lock but i still comes out relatively easy, so i don't know if thats it.

After i switched those screens and connected everything i've gotten a white screen. (The sound still works though everything does actually except the screen itself)

I've read that i had to try and push on connector 1, straighten out the wires and clean them, but none of those things worked out.

I'm thinking it might be one of the connectors or the lcd itself might be the problem.

I hope you guys can help me with this though.

Thanks in advance.

Gerät:

iPhone 3GS

Status:

open