Zum Hauptinhalt wechseln
Hilfe

Aktuelle Version von: oldturkey03 ,

Titel:

Digitizer ghost entries. (Going crazy)

Text:

Have done several of these digitizer replacements.

Originally the customer dropped the iPad3, denting the back casing on the side at the volume control. This jammed the volume button in, causing the vol dialog box to stay stuck on screen at the vol down position.

Disassembled the device, removed busted digitizer, carefully bent the casing back and painstakingly got it back flat to where it would accommodate a new screen trim bezel. Installed a new digitizer. And voila everything is working, looks great, and can barely tell it was ever dropped.

HOWEVER.. Right of the bat I am getting ghost entries. Holding the ipad right side up with the Apple button at the bottom, the area that appears to be performing ghost entries is in the M to I range on the keyboard(in the right side up position.

What could be causing this? Bad Digitizer? Ribbon not seated properly? It is driving me insane. And the iPad is performing like it IS insane. It is unusable in this state, and the customer is growing impatient.

I hate having to redo this again, and potentially breaking the digitizer removing it again. Not to mention getting it back on, having to redo the adhesive, etc.

PLEASE HELP!

THANKS IN ADVANCE!

Gerät:

-Apple iPad 3 (A1430)
+iPad 3 4G

Status:

open

Ursprünglicher Beitrag von: Triple X ,

Titel:

Digitizer ghost entries. (Going crazy)

Text:

Have done several of these digitizer replacements.

Originally the customer dropped the iPad3, denting the back casing on the side at the volume control. This jammed the volume button in, causing the vol dialog box to stay stuck on screen at the vol down position.

Disassembled the device, removed busted digitizer, carefully bent the casing back and painstakingly got it back flat to where it would accommodate a new screen trim bezel. Installed a new digitizer. And voila everything is working, looks great, and can barely tell it was ever dropped.

HOWEVER.. Right of the bat I am getting ghost entries. Holding the ipad right side up with the Apple button at the bottom, the area that appears to be performing ghost entries is in the M to I range on the keyboard(in the right side up position.

What could be causing this? Bad Digitizer? Ribbon not seated properly? It is driving me insane. And the iPad is performing like it IS insane. It is unusable in this state, and the customer is growing impatient.

I hate having to redo this again, and potentially breaking the digitizer removing it again. Not to mention getting it back on, having to redo the adhesive, etc.

PLEASE HELP!

THANKS IN ADVANCE!

Gerät:

Apple iPad 3 (A1430)

Status:

open