Zum Hauptinhalt wechseln
Hilfe

Aktuelle Version von: L Pfaff ,

Text:

-brentkhack , It sounds like a connector or a component may have come loose. Open the device and clean all the connections battery, display, etc., with a Qtip dampened with 90% or better Isopropyl Alcohol and reseat the connectors to ensure good connection and use a magnifier to check for missing, loose, damaged components. Check battery with DVOM to ensure battery is good and charged. Good luck.
+brentkhack , It sounds like a connector or a component may have come loose. Open the device and clean all the connections battery, display, etc., with a Qtip dampened with 90% or better Isopropyl Alcohol, look for any damage pins/terminals and reseat the connectors to ensure good connection and use a magnifier to check for missing, loose, damaged components. Check battery with DVOM to ensure battery is good and charged. Good luck.
I hope this helped you out, if so let me know by pressing the helpful button.

Status:

open

Ursprünglicher Beitrag von: L Pfaff ,

Text:

brentkhack , It sounds like a connector or a component may have come loose. Open the device and clean all the connections battery, display, etc., with a Qtip dampened with 90% or better Isopropyl Alcohol and reseat the connectors to ensure good connection and use a magnifier to check for missing, loose, damaged components. Check battery with DVOM to ensure battery is good and charged. Good luck.

I hope this helped you out, if so let me know by pressing the helpful button.

Status:

open