Zum Hauptinhalt wechseln
Hilfe

Aktuelle Version von: Daniel ,

Titel:

Device freezes after a few minutes of usage

Text:

Hello everyone.
In the hopes of getting a good deal online, I found a faulty Nintendo Switch that would not charge, so I thought I would be able to may be fix the problem. Allthough I have (probably) found the reason why the device does not charge (which is because of a crooked component I cannot identify next to the charging ic of the Switch (see [http://www.westingames.com/productPic/20170712/font201707120956398462.jpg|here]), I also noticed that even when there was enough power left, the device would freeze after a few minutes of usage, no matter whether I am doing something processing intensive or just waiting in the menu. It appears that the device is trying to check for something and then hangs up because it returns something wrong.
Perhaps anyone has further information regarding this issue?
I would certainly be happy to know.
Thanks!
=== Update (12/12/2017) ===
So I believe I managed to find more information about my problem.
Firstly, I have likely found what is causing the system to freeze after turning it on: It freezes when the power supply chip M92T36 is trying to read the current battery percentage. I know this because while the system is running and it hasn't crashed yet, the battery percentage stays the same. The percentage never seems to fall or rise actively. By the time the percentage should change, the system freezes, and I '''have''' to unplug the internal battery and then reconnect it to get the system to boot up again. After unplugging and restarting, the system shows the new battery percentage, but as I already mentioned, I can never see the power level actively drop, so it must be a problem with the power management IC.
Now that we understand the problem, I started to look for obvious hints of something being wrong with the charging chip. And by no surprise
[image|1295534]
I found a missing component, marked in red, that I retrieved hanging around from somewhere across the board. If we look up the datasheet of the IC [http://www.rohm.co.jp/web/japan/datasheet/BM92A30MWV/bm92a30mwv-e|here] on page 4-5, we can see that pin 2 of the chip labelled VSTR/ATST2 is responsible for "Analog TEST/ Debug Pin2", so I might assume that this pin os responsible for measuring the battery voltage and thus its charge.
Since the switch is reading an analog signal from this pin, and it does not receive any, the chip returns an unknown value to the switch and is system freezes because of that. At least this would be my suspicion.
Regardless, I have tried (and failed) putting the resistor back into place, as hot air does not make the thing seem to work, and I also tried bridgin the spot so that there again was a connection (even though without a resistor then). I am not sure if it is worth getting the resistor back in place, and if this is even the cause of the problem, especially because the chip looked like this when I first looked at it
[image|1295558]
, so perhaps something else got bad?
All of this makes sense to me, but I am not quite sure how to attempt to solve or repair it, and ordering a completely new Power supply IC would take multiple weeks to arrive, just to find out that replacing the chip didnt help.
-If just pcb shematics and wiring diagrams were available for the switch... Anyways, any help is still appreciated!
+If just pcb shematics and wiring diagrams were available for the switch... Anyways, any help is still appreciated!
=== Update (13.12.2017) ===
-Little update. I tried hooking up a potentiometer where the original resistor would be and tweaked it to different resistances, to see if the device would finally stop crashing after a while (like this) [image|1296309]
+Little update. I tried hooking up a potentiometer where the original resistor would be and tweaked it to different resistances, to see if the device would finally stop crashing after a while (like this)
+
+[image|1296309]
Unsurprisingly, that did not fix the problem. I did notice that, when listening very closely, the switch would make a high pitched noise, probably caused by some coils or chips, and when the device freezes, the sounds would stop. I am planning on running further experiments such as checking how much current is flowing when its running against when it froze, or if the freezing is caused by any overheating in certain parts of the mainboard. If all else fails I will try replacing the USB-C power management chip.
And as usual, let me know if anyone has a similar problem!

Gerät:

Nintendo Switch

Status:

open

Akzeptierte Antwort:

+447715

Bearbeitet von: Daniel ,

Titel:

Device freezes after a few minutes of usage

Text:

Hello everyone.
In the hopes of getting a good deal online, I found a faulty Nintendo Switch that would not charge, so I thought I would be able to may be fix the problem. Allthough I have (probably) found the reason why the device does not charge (which is because of a crooked component I cannot identify next to the charging ic of the Switch (see [http://www.westingames.com/productPic/20170712/font201707120956398462.jpg|here]), I also noticed that even when there was enough power left, the device would freeze after a few minutes of usage, no matter whether I am doing something processing intensive or just waiting in the menu. It appears that the device is trying to check for something and then hangs up because it returns something wrong.
Perhaps anyone has further information regarding this issue?
I would certainly be happy to know.
-Thanks!
+Thanks!
=== Update (12/12/2017) ===
So I believe I managed to find more information about my problem.
Firstly, I have likely found what is causing the system to freeze after turning it on: It freezes when the power supply chip M92T36 is trying to read the current battery percentage. I know this because while the system is running and it hasn't crashed yet, the battery percentage stays the same. The percentage never seems to fall or rise actively. By the time the percentage should change, the system freezes, and I '''have''' to unplug the internal battery and then reconnect it to get the system to boot up again. After unplugging and restarting, the system shows the new battery percentage, but as I already mentioned, I can never see the power level actively drop, so it must be a problem with the power management IC.
-Now that we understand the problem, I started to look for obvious hints of something being wrong with the charging chip. And by no surprise
+Now that we understand the problem, I started to look for obvious hints of something being wrong with the charging chip. And by no surprise
+
[image|1295534]
I found a missing component, marked in red, that I retrieved hanging around from somewhere across the board. If we look up the datasheet of the IC [http://www.rohm.co.jp/web/japan/datasheet/BM92A30MWV/bm92a30mwv-e|here] on page 4-5, we can see that pin 2 of the chip labelled VSTR/ATST2 is responsible for "Analog TEST/ Debug Pin2", so I might assume that this pin os responsible for measuring the battery voltage and thus its charge.
Since the switch is reading an analog signal from this pin, and it does not receive any, the chip returns an unknown value to the switch and is system freezes because of that. At least this would be my suspicion.
-Regardless, I have tried (and failed) putting the resistor back into place, as hot air does not make the thing seem to work, and I also tried bridgin the spot so that there again was a connection (even though without a resistor then). I am not sure if it is worth getting the resistor back in place, and if this is even the cause of the problem, especially because the chip looked like this when I first looked at it [image|1295558], so perhaps something else got bad?
+Regardless, I have tried (and failed) putting the resistor back into place, as hot air does not make the thing seem to work, and I also tried bridgin the spot so that there again was a connection (even though without a resistor then). I am not sure if it is worth getting the resistor back in place, and if this is even the cause of the problem, especially because the chip looked like this when I first looked at it
+
+[image|1295558]
+
+, so perhaps something else got bad?
All of this makes sense to me, but I am not quite sure how to attempt to solve or repair it, and ordering a completely new Power supply IC would take multiple weeks to arrive, just to find out that replacing the chip didnt help.
-If just pcb shematics and wiring diagrams were available for the switch... Anyways, any help is still appreciated!
+If just pcb shematics and wiring diagrams were available for the switch... Anyways, any help is still appreciated!
+
+=== Update (13.12.2017) ===
+
+Little update. I tried hooking up a potentiometer where the original resistor would be and tweaked it to different resistances, to see if the device would finally stop crashing after a while (like this) [image|1296309]
+
+Unsurprisingly, that did not fix the problem. I did notice that, when listening very closely, the switch would make a high pitched noise, probably caused by some coils or chips, and when the device freezes, the sounds would stop. I am planning on running further experiments such as checking how much current is flowing when its running against when it froze, or if the freezing is caused by any overheating in certain parts of the mainboard. If all else fails I will try replacing the USB-C power management chip.
+
+And as usual, let me know if anyone has a similar problem!

Gerät:

Nintendo Switch

Status:

open

Bearbeitet von: Daniel ,

Titel:

Device freezes after a few minutes of usage

Text:

Hello everyone.
In the hopes of getting a good deal online, I found a faulty Nintendo Switch that would not charge, so I thought I would be able to may be fix the problem. Allthough I have (probably) found the reason why the device does not charge (which is because of a crooked component I cannot identify next to the charging ic of the Switch (see [http://www.westingames.com/productPic/20170712/font201707120956398462.jpg|here]), I also noticed that even when there was enough power left, the device would freeze after a few minutes of usage, no matter whether I am doing something processing intensive or just waiting in the menu. It appears that the device is trying to check for something and then hangs up because it returns something wrong.
Perhaps anyone has further information regarding this issue?
I would certainly be happy to know.
-Thanks!
+Thanks!
+
+=== Update (12/12/2017) ===
+
+So I believe I managed to find more information about my problem.
+
+Firstly, I have likely found what is causing the system to freeze after turning it on: It freezes when the power supply chip M92T36 is trying to read the current battery percentage. I know this because while the system is running and it hasn't crashed yet, the battery percentage stays the same. The percentage never seems to fall or rise actively. By the time the percentage should change, the system freezes, and I '''have''' to unplug the internal battery and then reconnect it to get the system to boot up again. After unplugging and restarting, the system shows the new battery percentage, but as I already mentioned, I can never see the power level actively drop, so it must be a problem with the power management IC.
+
+Now that we understand the problem, I started to look for obvious hints of something being wrong with the charging chip. And by no surprise
+[image|1295534]
+
+I found a missing component, marked in red, that I retrieved hanging around from somewhere across the board. If we look up the datasheet of the IC [http://www.rohm.co.jp/web/japan/datasheet/BM92A30MWV/bm92a30mwv-e|here] on page 4-5, we can see that pin 2 of the chip labelled VSTR/ATST2 is responsible for "Analog TEST/ Debug Pin2", so I might assume that this pin os responsible for measuring the battery voltage and thus its charge.
+
+Since the switch is reading an analog signal from this pin, and it does not receive any, the chip returns an unknown value to the switch and is system freezes because of that. At least this would be my suspicion.
+
+Regardless, I have tried (and failed) putting the resistor back into place, as hot air does not make the thing seem to work, and I also tried bridgin the spot so that there again was a connection (even though without a resistor then). I am not sure if it is worth getting the resistor back in place, and if this is even the cause of the problem, especially because the chip looked like this when I first looked at it [image|1295558], so perhaps something else got bad?
+
+All of this makes sense to me, but I am not quite sure how to attempt to solve or repair it, and ordering a completely new Power supply IC would take multiple weeks to arrive, just to find out that replacing the chip didnt help.
+
+If just pcb shematics and wiring diagrams were available for the switch... Anyways, any help is still appreciated!

Gerät:

Nintendo Switch

Status:

open

Ursprünglicher Beitrag von: Daniel ,

Titel:

Device freezes after a few minutes of usage

Text:

Hello everyone.

In the hopes of getting a good deal online, I found a faulty Nintendo Switch that would not charge, so I thought I would be able to may be fix the problem. Allthough I have (probably) found the reason why the device does not charge (which is because of a crooked component I cannot identify next to the charging ic of the Switch (see [http://www.westingames.com/productPic/20170712/font201707120956398462.jpg|here]), I also noticed that even when there was enough power left, the device would freeze after a few minutes of usage, no matter whether I am doing something processing intensive or just waiting in the menu. It appears that the device is trying to check for something and then hangs up because it returns something wrong.

Perhaps anyone has further information regarding this issue?

I would certainly be happy to know.

Thanks!

Gerät:

Nintendo Switch

Status:

open