Zum Hauptinhalt wechseln
Hilfe

Aktuelle Version von: Wizzzz ,

Titel:

Buzz sound in call after dock assembly change

Text:

Hi,
 
I replaced my dock assembly on my 3GS as the speaker stopped working.
 
After replacing it I found that I couldn't get a signal. I then took the antenna from the original dock assembly and swapped it with the dodgy one from the new dock assembly which fixed the no signal issue.
 
But, now every time I am on a call I can hear a buzz in the speaker and the person on the other end can also hear this.
 
Can anyone suggest what may have caused this?
 
How can I fix it?
 
Thanks!
 
== Update ==
 
Must have been some sort of a grounding issue.
 
I ended up soldering the new speaker to the original dock connector/mic and attached the original antenna.
 
It's all working perfectly now.

Gerät:

iPhone 3GS

Status:

open

Akzeptierte Antwort:

49415

Bearbeitet von: Wizzzz ,

Titel:

Buzz sound in call after dock assembly change

Text:

Hi,

I replaced my dock assembly on my 3GS as the speaker stopped working.

After replacing it I found that I couldn't get a signal. I then took the antenna from the original dock assembly and swapped it with the dodgy one from the new dock assembly which fixed the no signal issue.

But, now every time I am on a call I can hear a buzz in the speaker and the person on the other end can also hear this.

Can anyone suggest what may have caused this?

How can I fix it?

Thanks!

Gerät:

iPhone 3GS

Status:

open

Akzeptierte Antwort:

49415

Ursprünglicher Beitrag von: Wizzzz ,

Titel:

Buzz sound in call after dock assembly change

Text:

Hi,

I replaced my dock assembly on my 3GS as the speaker stopped working.

After replacing it I found that I couldn't get a signal. I then took the antenna from the original dock assembly and swapped it with the dodgy one from the new dock assembly which fixed the no signal issue.

But, now every time I am on a call I can hear a buzz in the speaker and the person on the other end can also hear this.

Can anyone suggest what may have caused this?

How can I fix it?

Thanks!

Gerät:

iPhone 3GS

Status:

open