Zum Hauptinhalt wechseln

Repariere deine Sachen

Recht auf Reparatur

Werkzeug & Ersatzteile

Hilfe

Aktuelle Version von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!
 
'''Edit 2018-07-06''': Here is the logic board in pictures:
 
[image|1496247]
 
[image|1496260]
 
'''Edit 2018-07-13''' : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
 
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)
 
Here are the mosfet voltages:
 
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?
 
Here are the mosfet pins I measured, just to be sure:
 
[image|1500816]
 
[image|1500808]
 
I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...
 
Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
 
[image|1500806]
 
I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.
 
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?
 
'''Edit 2018-07-16''' : Okay so with your corrections I remade a schema and took again voltages and resistances:
 
[image|1502846]
 
Can you confirm if I've written the right components?
 
The backlight was fine a few weeks ago, it stopped working suddenly and they gave me the computer without any human intervention.
The backlight was fine a few weeks ago, it stopped working suddenly and they gave me the computer without any human intervention.
 
I wonder if there is something wrong with R9720. Either it's a faulty contact between the circuit and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.
I wonder if there is something wrong with R9720. Either it's a faulty contact between the circuit and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.
 
'''Edit 2018-07-17''': R9720 is not assembled as specified in the schema ("NO STUFF" = do not stuff, do not assemble), so it's open circuit.

'''Edit 2018-07-18''': I had to give back the iMac today... They'll go to an Apple store to get a repair estimate. I hope to know how it ends, for the sake of curiosity...
'''Edit 2018-07-17''': R9720 is not assembled as specified in the schema ("NO STUFF" = do not stuff, do not assemble), so it's open circuit.

'''Edit 2018-07-18''': I had to give back the iMac today... They'll go to an Apple store to get a repair estimate. I hope to know how it ends, for the sake of curiosity...

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!
 
'''Edit 2018-07-06''': Here is the logic board in pictures:
 
[image|1496247]
 
[image|1496260]
 
'''Edit 2018-07-13''' : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
 
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)
 
Here are the mosfet voltages:
 
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?
 
Here are the mosfet pins I measured, just to be sure:
 
[image|1500816]
 
[image|1500808]
 
I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...
 
Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
 
[image|1500806]
 
I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.
 
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?
 
'''Edit 2018-07-16''' : Okay so with your corrections I remade a schema and took again voltages and resistances:
 
[image|1502846]
 
Can you confirm if I've written the right components?
 
I wonder if there is something wrong with R9720. Either it'sThe backlight was fine a faulty contact between the circuitfew weeks ago, it stopped working suddenly and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side ofthey gave me the board.computer without any human intervention.
I wonder if there is something wrong with R9720. Either it'sThe backlight was fine a faulty contact between the circuitfew weeks ago, it stopped working suddenly and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side ofthey gave me the board.computer without any human intervention.
 
The backlight was fineI wonder if there is something wrong with R9720. Either it's a few weeks ago, it stopped working suddenlyfaulty contact between the circuit and they gave memy multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.

'''Edit 2018-07-17''': R9720 is not assembled as specified in
the computer without any human interventionschema ("NO STUFF" = do not stuff, do not assemble), so it's open circuit.
The backlight was fineI wonder if there is something wrong with R9720. Either it's a few weeks ago, it stopped working suddenlyfaulty contact between the circuit and they gave memy multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.

'''Edit 2018-07-17''': R9720 is not assembled as specified in
the computer without any human interventionschema ("NO STUFF" = do not stuff, do not assemble), so it's open circuit.

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!
 
'''Edit 2018-07-06''': Here is the logic board in pictures:
 
[image|1496247]
 
[image|1496260]
 
'''Edit 2018-07-13''' : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
 
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)
 
Here are the mosfet voltages:
 
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?
 
Here are the mosfet pins I measured, just to be sure:
 
[image|1500816]
 
[image|1500808]
 
I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...
 
Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
 
[image|1500806]
 
I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.
 
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?
 
'''Edit 2018-07-16''' : Okay so with your corrections I remade a schema and took again voltages and resistances:
 
[image|1502842image|1502846]
[image|1502842image|1502846]
 
Can you confirm if I've written the right components?
 
I wonder if there is something wrong with R9720. Either it's a faulty contact between the circuit and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.
 
The backlight was fine a few weeks ago, it stopped working suddenly and they gave me the computer without any human intervention.

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!
 
'''Edit 2018-07-06''': Here is the logic board in pictures:
 
[image|1496247]
 
[image|1496260]
 
'''Edit 2018-07-13''' : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
 
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)
 
Here are the mosfet voltages:
 
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?
 
Here are the mosfet pins I measured, just to be sure:
 
[image|1500816]
 
[image|1500808]
 
I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...
 
Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
 
[image|1500806]
 
I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.
 
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?

'''Edit 2018-07-16''' : Okay so with your corrections I remade a schema and took again voltages and resistances:

[image|1502842]

Can you confirm if I've written the right components?

I wonder if there is something wrong with R9720. Either it's a faulty contact between the circuit and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.

The backlight was fine a few weeks ago, it stopped working suddenly and they gave me the computer without any human intervention.
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?

'''Edit 2018-07-16''' : Okay so with your corrections I remade a schema and took again voltages and resistances:

[image|1502842]

Can you confirm if I've written the right components?

I wonder if there is something wrong with R9720. Either it's a faulty contact between the circuit and my multimeter or the resistance is absent (?), dead or unsoldered. I cannot see because it's hidden on the other side of the board.

The backlight was fine a few weeks ago, it stopped working suddenly and they gave me the computer without any human intervention.

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!
 
== Edit 2018-07-06 ==
Here
'''Edit 2018-07-06''': Here is the logic board in pictures:
== Edit 2018-07-06 ==
Here
'''Edit 2018-07-06''': Here is the logic board in pictures:
 
[image|1496247]
 
[image|1496260]
 
Edit 2018-07-13'''Edit 2018-07-13''' : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
Edit 2018-07-13'''Edit 2018-07-13''' : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
 
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)
 
Here are the mosfet voltages:
 
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?
 
Here are the mosfet pins I measured, just to be sure:
 
[image|1500816]
 
[image|1500808]
 
I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...
 
Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
 
[image|1500806]
 
I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.
 
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!
 
Edit== Edit 2018-07-06 : Here==
Here
is the logic board in pictures:
Edit== Edit 2018-07-06 : Here==
Here
is the logic board in pictures:
 
[image|1496247]
 
[image|1496260]
[image|1496260]
 
Edit 2018-07-13 : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
 
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)
 
Here are the mosfet voltages:
 
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?
 
Here are the mosfet pins I measured, just to be sure:
 
[image|1500816]
 
[image|1500808]
 
I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...
 
Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
 
[image|1500806]
 
I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.
 
You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!
Thank you and have a great day!
 
Edit 07-06-20182018-07-06 : Here is the logic board in pictures:
Edit 07-06-20182018-07-06 : Here is the logic board in pictures:
 
[image|1496247] [image|1496260]

[image|1496260]

Edit 2018-07-13 : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)

Here are the mosfet voltages:
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?

Here are the mosfet pins I measured, just to be sure:
[image|1500816]
[image|1500808]

I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...

Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
[image|1500806]

I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.

You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?
[image|1496247] [image|1496260]

[image|1496260]

Edit 2018-07-13 : @oldturkey03 you asked me to check some voltages. So the fuse F9700 is ok and there is 12V. But there is 0V at the resistor R9704. The mosfet (FDMS6681Z, named Q9702 in the schema) seems fine:
* Rgd = 112 kOhm
* Rsg = 71 kOhm
* Rsd = 36,3 kOhm (keeps increasing, capacitance effect?)

Here are the mosfet voltages:
* Vg = 12V
* Vs = 12V : is it normal?
* Vd = 0V : should be 12V, right?

Here are the mosfet pins I measured, just to be sure:
[image|1500816]
[image|1500808]

I tried to look around for damaged stuff but I cannot find the schema components on the logic board: Q9701, R9720, R9721, C9771...

Also I found a component that seemed damaged to me, the one with a question mark and a red circle on the previous picture. Check this:
[image|1500806]

I thought it was a damaged capacitor but I only had a multimeter to test it. I unsoldered it and it looked like a 45 kOhm resistor, package 1206. It was a bit hard for me to solder it back. Maybe I overheated because at the end I measured 35 kOhm, but the iMac is still booting, phew.

You seem to know this circuit pretty well, do you know where I should check now, and do you know the name of the component I just abused lol?

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, cause: mainboard?

Text:

Hello,
 
I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.
 
Here is what I found:
 
* All four diagnostic LED are on
 
* I can connect to an external display
 
* I bought another iMac LCD on eBay but same result : nothing is displayed
 
* After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.
 
* I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.
 
* I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.
 
So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.
 
I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.
 
First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?
 
Any support would be greatly appreciated :)
 
Thank you and have a great day!

Edit 07-06-2018 : Here is the logic board in pictures:

[image|1496247] [image|1496260]
Thank you and have a great day!

Edit 07-06-2018 : Here is the logic board in pictures:

[image|1496247] [image|1496260]

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Bearbeitet von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, probably mainboardcause: mainboard?
LCD Backlight & one ram slot dead, probably mainboardcause: mainboard?

Text:

Hello,

I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.

Here is what I found:

*  All four diagnostic LED are on

*  I can connect to an external display

*  I bought another iMac LCD on eBay but same result : nothing is displayed

*  After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.

*  I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.

*  I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.

So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.

I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.

First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?

Any support would be greatly appreciated :)

Thank you and have a great day!

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open

Ursprünglicher Beitrag von: Antoine Merino ,

Titel:

LCD Backlight & one ram slot dead, probably mainboard

Text:

Hello,

I was recently entrusted with a late 2012 21,5" iMac (EMC 2544) to repair. The problem was there was no display anymore.

Here is what I found:

*  All four diagnostic LED are on

*  I can connect to an external display

*  I bought another iMac LCD on eBay but same result : nothing is displayed

*  After looking for answers on the Internet I found that the backlight could be the cause: indeed, if I light the LCD with a torch I can see the pixels, so only the backlight is not working. Then I sent back the LCD I just bought.

*  I found also that a dimm slot (slot 0) doesn't detect the RAM, however this RAM is detected on another laptop. This is not a priority repair, but it might help to find the root cause of the broken backlight.

*  I totally disassembled the iMac without seeing any evident damage on the mainboard, but I think I missed something. Unfortunately I didn't take any good enough pictures and I reassembled it fully.

So far I'm trying to understand the circuit posted here ([post|366379]) by @oldturkey03. Maybe a component died and it may have cause both the dimm slot and the LCD backlight to stop working. I cannot tell if the ram slot stopped working before or at the same time as the backlight.

I'm use to do repairs on PCs and smartphones when it is about changing whole pieces (LCD, mainboards...). However changing this iMac mainboard is really expensive. I also have basics on soldering and electronics and can read simple schematics (recent graduate engineer in embedded systems, yey) so I feel like I'm able to give it a try and I have nothing to loose (except my time), but for sure I do need your help on this one.

First, I am not used to Macs, did I forget to check something evident on this machine? If not, where should I start to check if some related components are dead?

Any support would be greatly appreciated :)

Thank you and have a great day!

Gerät:

iMac Intel 21.5" EMC 2544

Status:

open