Zum Hauptinhalt wechseln
Hilfe

Aktuelle Version von: Nuno Soares ,

Text:

Hi, I have the same problem. Done everything according to instructions. In fact it was easy to remove the screen since the glue was already not adhering to both right and left sides of the screen, so only bottom and top was glued.
Carefully removed the rest and clean it thoroughly, in fact that was easy. The difficult part was removing the bottom plate because one of the screws was so stuck and I ended damaging it no allowing to remove it. Fortunatelly was on the farthest side of the battery connector, so I was able to remove it and insert from the new battery.
-As the screen was OK, I reinstalled it, making sure the connectors are aligned with the white stripes. It looks more aligned on the left side than on the right side… Screen is working fine, but no touch… Only way I managed to access my phone is using an OTG cable to connect a keyboard and mouse. Did a factory reset hoping to get things normal, but nothing, still no touch.
+As the screen was OK, I reinstalled it, making sure the connectors are aligned with the white stripes. It looks more aligned on the left side than on the right side… Screen is working fine, but no touch… Only way I managed to access my phone is using an OTG cable to connect a keyboard and mouse. Did a factory reset hoping to get things normal, but nothing, still no touch. I still haven’t glues the screen, do I need to? Are there some contacts that I am not aware?
Quite frustrating! Did I miss something? Did I do something wrong? Help me, please!!!

Status:

open

Ursprünglicher Beitrag von: Nuno Soares ,

Text:

Hi, I have the same problem. Done everything according to instructions. In fact it was easy to remove the screen since the glue was already not adhering to both right and left sides of the screen, so only bottom and top was glued.

Carefully removed the rest and clean it thoroughly, in fact that was easy. The difficult part was removing the bottom plate because one of the screws was so stuck and I ended damaging it no allowing to remove it. Fortunatelly was on the farthest side of the battery connector, so I was able to remove it and insert from the new battery.

As the screen was OK, I reinstalled it, making sure the connectors are aligned with the white stripes. It looks more aligned on the left side than on the right side… Screen is working fine, but no touch… Only way I managed to access my phone is using an OTG cable to connect a keyboard and mouse. Did a factory reset hoping to get things normal, but nothing, still no touch.

Quite frustrating! Did I miss something? Did I do something wrong? Help me, please!!!

Status:

open