Zum Hauptinhalt wechseln

Mid 2010 Modell A1278 / 2,4 oder 2,66 GHz Core 2 Duo Prozessor

856 Fragen Alle anzeigen

Mac doesn't boot from internal HDD but does from USB plug?

Hello there :D

I'm stuck in a weird position here. My roommate gave me a MacBook Pro mid-2010 which had vodka/orange juice spilled on it. Not working, I tore it down, cleaned the hardware. And as I saw the fan spilling when i took everything apart, I said myself I can fix it !

I mount everything back in, turn it on : Grey screen Yeah !! I then installed everything start to use it. But it has crashed. No way to boot the system up : question mark on a folder. PRAM reset put it back on the road again. Then it crashed again.

I did all of the resets I know something about (PRAM, SMC), but nothing. And the weird thing is that it boot up normally when the very same drive is plugged externally through USB port... I'm actually using it to open this thread !

Whats wrong with the mobo ? (I did unplugged energy sources for days, just in case)

Beantwortet! View the answer Ich habe das gleiche Problem

Ist dies eine gute Frage?

Punktzahl 0
Einen Kommentar hinzufügen

Android Fix Kits

A new screen or battery is one kit away.

Jetzt kaufen

Android Fix Kits

A new screen or battery is one kit away.

Jetzt kaufen

2 Antworten

Gewählte Lösung

If you want to check which part is exactly not working. you can boot with MAC OSX dvd or any windows DVD or CD. Check hard drive is preset or not . if after booting drives are visible then it means Operating system is actually a corrupted. if drives are not there then HDD or HDD cable or logic board is faulty.

First change the drive and check.

Change the HDD cable. if donot have cable try this hard drive on external casing.

after changing the cable also not working then loGic board need repair to need to change .

Check the liquid spillage near the HDD cable jack on Logic board. Clean it properly . then try to boot. thnx

War diese Antwort hilfreich?

Punktzahl 1

Kommentare:

Did you read me ? I tried from external test : it work . I don't have any DVD or CD I will try with an live CD of debian, just in case. But I already reinstalled the software so ... dunno

von

Update : No HDD detected ! I'll change the cable. But the point is "How can you destroy a cable by shutting down a computer ?? According to me, the logicboard is the responsible of all this

von

Double check for corrosion on the ends of the cable and the connecters it plugs into. Good luck.

von

Nothing, of course ... --'

von

To give an answer, the cable was the responsible of all this ! Thanks for your help, both. I was ready to change everything for a tiny cable ...

von

Einen Kommentar hinzufügen
Hilfreichste Antwort

Either the connector/logic board is damaged at the HD or the HD itself is damaged. If you can run AHT from the USB drive it it may point to problem. The "shade tree mechanic's" DIY solution wold be to buy a new HD install it and see if your problem goes away. If it doesn't then you're looking at a logic board replacement and you'll have to determine if it's cost effective.

If this Answer is helpful please remember to return and mark it Accepted.

War diese Antwort hilfreich?

Punktzahl 1

Kommentare:

First of all : Thanks for your answer !

I heard about the AHT, and I know that this will resolve my problem. But I don't have any DVD or USB key delivered with the mac. So I ran the Network AHT with the Option-D combo. And the tester says Your mac is not supported, which can normally resolved by updating the EFI and SMC which are up to date.

I just ran HDD tests : SMART Ok and the DD is perfectly working ...

von

Edit : I managed to start the AHT by installing a PKG made and published on the web. I'll keep you in touch :)

von

Hello again !

It did the fast one and the extended one (still trough USB) And nothing seems to be malfunctionning.

But the AHT don't start from the s'ATA plug ... I'll probably change the cable

von

Sometimes you have to run the extended AHT 2 or 3x in a row to have a problem show up (especially if it is an intermittent one).

von

Actually, I did it a quick one then 2 extended ones, reboot the thing with the HDD inside then a second quick one with the HDD plugged through USB. And still nothing. I'm waiting for a new HDD/IR sensor cable... will see :)

von

1 Weiteren Kommentar anzeigen

Einen Kommentar hinzufügen

Antwort hinzufügen

Valentin wird auf ewig dankbar sein.
Statistik anzeigen:

Letzte 24 Stunden: 2

Letzte 7 Tage: 13

Letzte 30 Tage: 61

Insgesamt: 7,273