Zum Hauptinhalt wechseln

Verkaufsstart Juni 2012, Model A1278. Intel Prozessor mit Turbo Boost, bis zu 512 MB DDR5 Video RAM

1279 Fragen Alle anzeigen

Problems with SSD after replacing cable

I had a SSD in my MacBook Pro 13'' mid 2012 working for some time, and one day it did not boot anymore, I tried reinstalling the system, recovering from Time Machine, pulling it out and reinstalling OS X on it through a USB case, all to no success.

I checked the SmartStatus with DriveDx (through another computer) and it had a huge count of UDMA Errors. I replaced the drive with a HDD and it worked, so I thought that maybe the SSD's controller went kaput (sent it back to the manufacturer, did not receive any news yet). I bought another SSD (brand new) put it in the MacBook, installed the system and as soon as I booted, started having freezing beach balls all the time. I ran BlackMagic Disk Speed Test and Read/Writes were around 120MB/s, way below what was expected.

Put the old HDD back, the computer worked OK, so I thought it was the cable that was damaged, not supporting higher speeds (strange thing is that the old SSD would not install or copy anything onto it).

Ordered a new cable, put it in, and here is where things get messy. With the HDD, no problem whatsoever. With the SSD, BlackMagic runs at 480MB/s (expected), but after some time, It starts freezing, I/O error counts sky rocket and if I shut it down and restart, I either get the question mark or the prohibit sign. If I wait long enough, it boots, so it seems that the problem is temperature related.

Any clues? Do I still have a faulty cable? Any help or insight is welcome.

Beantwortet! View the answer Ich habe das gleiche Problem

Ist dies eine gute Frage?

Punktzahl 1
Einen Kommentar hinzufügen

2 Antworten

Gewählte Lösung

I replaced the hard drive cable again. Seems that the one that I ordered and replaced was also faulty...

War diese Antwort hilfreich?

Punktzahl 1
Einen Kommentar hinzufügen
Hilfreichste Antwort

You have me scratching my head a bit here.

Your system has a SATA III (6.0 Gb/s) interface so you should be able to gain the fully bandwidth of your SSD.

By chance is your HD a SATA II (3.0 Gb/s) drive? If you can look I up, otherwise give us the make and model info.

For now check your systems firmware level. Follow this Apple T/N: About EFI and SMC firmware updates for Intel-based Mac computers.

War diese Antwort hilfreich?

Punktzahl 1

Kommentare:

It is a SATA III (Intel 7 chipset). The negotiated link speed is 6Gb/s (per System Report).

MacBook Pro 9,2

Boot ROM Version: MBP91.00D3.B0C

SMC Version (system): 2.2f41

von

How about the HD you were using what was it? Make & Model

von

Your SMC is out of date, it should be 2.2f44 (SMC 1.8). Also if you have El Capitan running your boot ROM would be newer (MBP81.0047.B2A).

von

The HD I'm using is a SanDisk Extreme Pro 480. I have El Capitan running, the boot rom seems to be the correct version, but you are correct, the SMC version is outdated. I'll have it updated and see if there are any changes.

von

You stated you have MBP91.00D3.B0C not the newer MBP81.0047.B2A. The Apple T/N is out of date the one I posted is updated by the OS installer.

von

5 Weitere Kommentare anzeigen

Einen Kommentar hinzufügen

Antwort hinzufügen

fernandodeschamps wird auf ewig dankbar sein.
Statistik anzeigen:

Letzte 24 Stunden: 0

Letzte 7 Tage: 0

Letzte 30 Tage: 2

Insgesamt: 363