Zum Hauptinhalt wechseln

Fix Your Stuff

Right to Repair

Parts & Tools

Das Apple iPhone 5s wurde am 10. September 2013 angekündigt. Die Reparatur dieses Geräts ist ähnlich wie bei den Vorgängermodellen und erfordert Schraubendreher und Hebelwerkzeuge. Verfügbar mit GSM oder CDMA mit 16, 32 oder 64 GB in silber, gold und space grau.

3965 Fragen Alle anzeigen

current draw fluctuating when power button pressed

Hi , i have an iphone 5s which had a charging issue , i changed the U2 and it was working fine i charged battery fully and phone was ok .

I replaced the shields ,put the phone back together and it didnt work .

took it apart again and found U1600 looked a bit damaged , i thought i was careful but maybe i caught it when replacing the shields , anyway i have changed U1600 but still the same .

when connected to dc power the amps fluctuate (see this video)

5S no boot

What does this indicate . ?

I have checked PP_BATT_VCC_CONN and its good 3.8 V

I thought on the schematic it listed the critical voltage lines but i cant seem to find them .

Beantwortet! View the answer Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0
Einen Kommentar hinzufügen

2 Antworten

Gewählte Lösung

Does the logic board still work without the shields? If so, I would add only one shield at a time and test. Then repeat if successful until you find which shield is causing the problem.

UPDATE (2017/05/02)

Just to recap, replacing U2 solved your charging problem but when you soldered the shields back on it failed to boot. Removing the shields didn't help and you then replaced U1600 because it looked damaged. Now the phone doesn't boot and the current draw fluctuates.

Does iTunes recognize your phone is connected? If not, then this still looks like a U2 (Tristar) problem. I don't know how experienced you are at micro-soldering so I'll suggest (no offence intended) that perhaps you may have applied too much heat when you put the shields back on. Let me know if I am concerned about this for nothing :>).

I would go back and test the main lines (BATT_VCC, VCC_MAIN, PP5V0_USB) as well as all of the voltage rails created by the PMIC (U7). I would also closely inspect the Tristar/PMIC/U1600 area for any (partially) dislodged components or solder bridges near the shield anchor points.

War diese Antwort hilfreich?

Bewertung 2

Kommentare:

No, shields are all off .

von

Hi ,sorry for the delay on answering , i Finally! , found some time to spend on this board , , yes thats correct the phone booted up fine and charged . I tunes does not see it when plugged in .

I put the shields back on by just touching the solder points with the iron tip , i thought maybe i pressed down a bit hard to get the solder points to line up (breaking the U1600).

I had a good look around the board for dislodged components as you suggested and found R78 was dislodged so i put that back on and was kind of hopeful but still same fault ,

i checked the voltage on PP_BATT_VCC :

These are all the components on that line , do i need to test voltage at all the components on a line to check a line ?

L4 3.8V

C332 3.8V

C333 3.8V

C337 3.8V

C3337 3.8V

C335 3.8V

C48_RF 3.8V

C42_RF 3.8V

C44_RF 3.8V

C43_RF 3.8V

C45_RF 3.8V

C51_RF 3.8V

C47_RF 3.8V

C46_RF 3.8V

C49_RF 3.8V

C1214_RF 3.8V

C100_RF 3.8V

C1201_RF 3.8V

C229_RF 3.8V

R32_RF 3.8V

C184_RF 3.8V

C118_RF 3.8V

C148_RF 3.8V

C242_RF 3.8V

C154_RF 3.8V

L5 3.8V

C387 3.8V

von

C386 3.8V

....

PP3V0_ACC is there and PP5V0_USB_PROT

the voltage on these lines fluctuate on and off with the amp draw on the psu .

von

Am i right in thinking pin E21 of U7 should have 3.3v , i have no volts on R131 .

von

You only need to check one component on a rail to get the right measurement. As for the TRISTAR_TO_PMU_USB_BRICKID line (R131) it should be 5.25V but I don't know under what conditions it will give that voltage.

If iTunes doesn't recognize your device, then it sounds to me like the Tristar replacement was not successful.

von

1 weiteren Kommentar anzeigen

Einen Kommentar hinzufügen

Hi ,sorry for the delay on answering , i Finally! , found some time to spend on this board , , yes thats correct the phone booted up fine and charged . I tunes does not see it when plugged in .

I put the shields back on by just touching the solder points with the iron tip , i thought maybe i pressed down a bit hard to get the solder points to line up (breaking the U1600).

I had a good look around the board for dislodged components as you suggested and found R78 was dislodged so i put that back on and was kind of hopeful but still same fault ,

i checked the voltage on PP_BATT_VCC :

These are all the components on that line , do i need to test voltage at all the components on a line to check a line ?

.

L4 3.8V

C332 3.8V

C333 3.8V

C337 3.8V

C3337 3.8V

C335 3.8V

C48_RF 3.8V

C42_RF 3.8V

C44_RF 3.8V

C43_RF 3.8V

C45_RF 3.8V

C51_RF 3.8V

C47_RF 3.8V

C46_RF 3.8V

C49_RF 3.8V

C1214_RF 3.8V

C100_RF 3.8V

C1201_RF 3.8V

C229_RF 3.8V

R32_RF 3.8V

C184_RF 3.8V

C118_RF 3.8V

C148_RF 3.8V

C242_RF 3.8V

C154_RF 3.8V

L5 3.8V

C387 3.8V

C386 3.8V

....

PP3V0_ACC is there and PP5V0_USB_PROT

the voltage on these lines fluctuate on and off with the amp draw on the psu .

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

markparnell1972 wird auf ewig dankbar sein.
Statistik anzeigen:

Letzten 24 Stunden: 0

Letzten 7 Tage: 3

Letzten 30 Tage: 15

Insgesamt: 716