Zum Hauptinhalt wechseln

Fix Your Stuff

Right to Repair

Parts & Tools

Modell A1418 / Ende 2012 / 2,7 & 2,9 GHz Core i5 oder 3,1 GHz Core i7 Prozessor

174 Fragen Alle anzeigen

No power but PSU is fine

So I'm trying to fix my iMac 21.5" late 2012 (EMC2544/A1418)

There is no response from the power button, no fans, no screen light up, no beeps, nothing. So basically it won't turn on.

First off, none of the diagnostic LEDs light up.

  • There is 12v measured on the logic board where the PSU plugs in.
  • There is 3v measured on the logic board where the PSU plugs in.
  • Coin cell voltage is 2.78v with computer unplugged.
  • I have tried resetting the real time clock.

When I hold the power button in and plug the power in trying to force it to turn the fans on into high power mode, nothing happens.

Anyone have any ideas? Seems like a fault on the logic board, but I'm not going to buy a new one. I'm hoping there is something simple that I've overlooked.

Beantwortet! View the answer Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 2

Kommentare:

Can you give us some background here on what happened just before the system died.

Did you have a lightning storm or other power disruption? Do you have your system plugged into a good surge suppressor or UPS?

What happens when you disconnect all of the peripherals (including keyboard & mouse) will the system power up then?

As you had opened the system did you note any burnt chips or smell anything burning?

von

Hi,

I came back from vacation and It just didn't turn on. I'm not sure if there was a power surge or not, it's not using a surge suppressor, and I do live in a lightning area.

von

Einen Kommentar hinzufügen

4 Antworten

Gewählte Lösung

Boy you are a bit of a gambler ;-{ Sadly I think you got snake eyes here. What likely happened was a lightning strike was close enough to hit your system (directly or indirectly)

I always recommend at least a surge suppressor to give your system a fighting chance its also important the other devices that connect to your system also have surge protection as the hit can travel in through any interconnected pathway. As an example lets say you have a wired Ethernet connection to your cable modem. Then a hit to the cable service could travel in through the Coax into the modem and onward to your iMac.

In any case I do recommend disconnecting any unnecessary peripherals from your system when you do go on vacation.

See of you can get your home owners insurance cover the repair. It sounds like you'll need a new logic board here.

Do take the time to get an electrician in to make sure your outlets & buildings grounding are in good shape. If you can swing it, get a good UPS as that offers even more protection.

War diese Antwort hilfreich?

Bewertung 0

Kommentare:

Yeah, I guess I was hoping the DB board breakers would save me. I always worry about cheep UPS putting out bad power, I guess bad power is better than the alternate.

von

Einen Kommentar hinzufügen

hey, where did you measured the 3V in the logic board?

i have the same imac, same issues, i purchased a new PSU and no luck.

btw. none of the diagnostic leds are on.

War diese Antwort hilfreich?

Bewertung 0

Kommentare:

I measured 3v on PSU at the power switch cable, then on the logic board I had 3v where the PSU plugs into the logic board (small cable), at the clock reset pads and at the coin voltage pads.

None of my LEDs lit up, but I did measure a TINY voltage increase at LED#1, but not enough to light it.

von

Yep, i got 3.4V at the PSU Power switch, 3.4V in the small cable conector and 2.94V at the coin voltage pads. and a 240mV rise in the LEDs.

Definitely a dead Logic Board =( ouch

von

Einen Kommentar hinzufügen

I have same problem at my A1418 21.5” Late 2012. The “fix” for me was to remove the PRAM battery, if i disconnect PRAM battery and insert it again it will work for one start up. If it goes long enough in sleep mode i have to redo the procedure. Therefore i have disconnected the PRAM battery entirely and works great for me. The next time i have to power it up i just have to unplug the charger cable for 5 sec(with PRAMremoved).

I always leave the cable in the iMac until i have to start it and therefore i don’t have to set up date and time. I have no interess in trying to repair the issue as it works great as it is.

I would recommend for you guys to try remove the PRAM and try to start it.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Try remove the clock battery and leave it outside and have power cord disconnected for 10 sec. That solved the issue with mine, I can't have clock battery in it otherwise it won't start. And if it goes to sleep or I power it off, I have to remove power cord again for 10 sec to get it to start.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

Nicholas Westmoreland wird auf ewig dankbar sein.
Statistik anzeigen:

Letzten 24 Stunden: 1

Letzten 7 Tage: 16

Letzten 30 Tage: 48

Insgesamt: 850