Replaced screen & drives - no more chime!

Hello,

I hope someone can help me with this: My daughter's iMac 2007 7,1 24" recently broke down half way with apparently a graphics card problem (single user mode works, graphical mode does not). So I went out and bought a used one. When I came to pick it up, the seller turned it on, and it started normally until the folder/question mark icon, which was OK because the seller had wiped the hard drive. The LCD had cloudy spots, and the seller stated that the DVD drive wasn't working. So I bought it, took it home, opened it, replaced the LCD with the one from the other machine, replaced the DVD and installed an SSD instead of the hard drive. I turned it on - no chime, black screen, of course no boot. Darn!

Here's some information:

  • When turned on, the fans behave normally (they shortly kick in at higher speed, then run at low RPM)
  • If I take the RAM out, I get the beeps for 'no RAM'
  • The PRAM battery is at the full 3V
  • The mouse has USB power
  • The Caps Lock key on the keyboard does NOT light up when pressed
  • I tried zapping the PRAM with the key combination - did not help, but I am not sure if the keyboard is being recognized because of the CapsLock thing
  • I tried 'resetting' the SMC (afaik a simple disconnect of power)
  • Diagnostic LEDs 1,2,3 turn on normally, 4 remains off

I figure that the first step must be a chime/POST success. As I said, the machine came up ok before, and I doubt that I have shot the main board by replacing the screen, HDD & DVD. The RAM is good. The hardware I installed worked on the old machine. For testing, I unplugged the LCD data cable on the old machine, and it chimed, LEDs 1,2,3 were on, LED4 off. Just what I expected.

So here are my questions:

1. Could a faulty/misinstalled cable (HDD etc, temperature sensors) prevent the machine from passing POST?

2. Would you recommend to try and restore the firmware via a restore CD? Will this even be possible if there is no chime? I am a little reluctant because the CD may get stuck in the drive and not come out again. Besides, how could the firmware have been damaged by the replacements I did?

3. What can I do to narrow down the cause for this? Unplug as much as possible?

Any help will be greatly appreciated.

Greetings from Germany,

Christoph

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0

Kommentare:

Your system has onboard diagnostics! Take a look at this: iMac Intel 24" EMC 2134 und 2211 Diagnose LEDs let us know what they are telling you. Good Luck!

von

Hi Dan, and thanks for your comment.

Well, as I wrote above: LED1-3 are on, LED4 is remains off, which is described as 'the CPU is communicating with the graphics card', but NOT 'video signal generated'.

But how does this information get me any closer to the goal of a chiming iMac?

Christoph

von

Einen Kommentar hinzufügen