Zum Hauptinhalt wechseln

Repariere deine Sachen

Recht auf Reparatur

Store

Modell A1311 / Mitte 2011 / 2.5 & 2.7 GHz Core i5 oder 2.8 GHz Core i7 Prozessor

450 Fragen Alle anzeigen

iMac shuts off then won’t boot

Hi all,

I could use some help repairing my 2011 21-inch iMac. It’s the first time I’m trying my hand at this sort of thing myself, so I admit that my decisions until now might not have been ideal.

The iMac has been broken since around a year ago. Less than two years prior, in late 2017, the GPU was replaced by an Apple authorized service provider. (The symptoms now are not at all like those from back then.)

Symptoms

When the computer has been off for awhile, it will happily boot. Everything will work fine with no indication that anything might be wrong.

But after some time, usually no more than 10 minutes, with no warning, the machine will shut off immediately. Then it tries but fails to reboot. For at least the next few hours it will not boot. Eventually, after waiting long enough, it will boot again and be usable for a few more minutes. Repeat.

When it refuses to boot, it will either

  • try to boot repeatedly, i.e. fans spin up, then stop, spin up again, indefinitely, or
  • try to boot once, fans spin up, then stop, spin up again and stay spun up. Display is off. Hard drive spinning I think, but no further audible activity, so it’s definitely not booting up without video. Apart from the lack of audible hard drive activity it sounds as if the machine is fully powered on.

Diagnostics

  • There’s nothing in the logs leading up to a shutdown that might indicate anything bad, the last log before shutdown is always something random.
  • Shutdowns also happen when not booting from the hard drive, e.g. in internet recovery mode.
  • The reported temperatures leading up to a shutdown are nowhere near extreme, so I don’t think it’s a cooling problem.
  • I swapped out the memory modules one by one. That’s not the cause (unless all of it has gone bad at once, which I’d say is unlikely)
  • While powered on in this zombie mode, only the first diagnostic LED is lit; according to the technician guide this means the machine isn’t turned on.
  • Disconnecting the display, hard drive, and optical drive does not help, so it seems they’re not to blame.
  • I haven’t found a way to run the diagnostic tests. Holding option-D results in an error code. Even if I could start a test, I think it’s very unlikely to finish before shutdown.

Attempts made

By the symptoms it seemed likely to me that the power supply was acting up, like a capacitor had burned out or something. So I bought a second-hand replacement and installed it. That did not solve the issue.

Then, to my non-specialist judgement, the next most likely candidate was the logic board. So I bought a replacement logic board, including CPU, and installed it. Lots of fun!

But of course, since I’m writing this here you know that did not solve it either.

Now I‘m not sure how to proceed.

The technician guide suggests replacing the internal power cables, but could it be as simple as a broken cable, given the symptoms? Should I suspect the GPU, given that it was replaced less than two years before the machine broke down again? Anything else I haven’t thought of?

I’d appreciate any help to further diagnose the problem. Constructive speculation based on the symptoms is also appreciated. Thanks.

Beantwortet! View the answer Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0

Kommentare:

Check to see if Apple installed the same type od defective GPU that is know to fail

von

They installed a Radeon HD 6770M, which is the model that originally came with it, and thus the same one that previously failed in my machine. But as far as I can tell it was never subject to an official repair program. The repair program only covered the 6970M in the 27-inch iMac. Was the 6770M known to fail too?

von

Einen Kommentar hinzufügen

1 Antwort

Gewählte Lösung

I finally bit the bullet and bought a replacement graphics card. (It’s a downgrade to the type of card in the base model but whatever, it was expensive enough as it is.) Installing it fixed the problem.

After detaching the previous card from the heatsink I saw that the VRAM chips had barely any of the gummy thermal pads left. They clearly weren’t replaced when the Apple-authorized service center replaced the card. So the most likely explanation is that those chips overheated, causing damage. Very amateurish of them. I won’t go there ever again.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

Josse Coen wird auf ewig dankbar sein.
Statistik anzeigen:

Letzten 24 Stunden: 0

Letzten 7 Tage: 0

Letzten 30 Tage: 10

Insgesamt: 77