Zum Hauptinhalt wechseln

I got this camera about a year ago, and now it wont charge.

I’ve tried charging my camera over night. I tried a new battery, and tried the Power reset as a similar question was solved. The camera works fine when connected to power with a usb cable, but the battery won’t charge, even if it says it is charging. I would really appreciate any tips on how to solve this. Thankyou.

Beantwortet! Antwort anzeigen Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 2
3 Kommentare

See if you can find an external charger.

von

I'll try that...

von

IT works with external power supply I have tried 3 differnent new battries

von

Einen Kommentar hinzufügen

3 Antworten

Gewählte Lösung

Found the problem. Thanks to @oldturkey03 we knew one of the batteries worked, and it was a problem in the camera.

We found a loose wire inside, so we soldered it back on, and it worked.

War diese Antwort hilfreich?

Bewertung 3

2 Kommentare:

Thanks everyone!

von

a loose wire on the inside means its time for me to get a new unit thanks mrdan

von

Einen Kommentar hinzufügen

@terfysg this “The camera works fine when connected to power with a usb cable” would mean that your power supply and cable are good. That will leave you with either a bad battery (yes, even a new one can be discharged below it’s threshold and will not charge) or a bad battery connection. Check the voltage on the battery with a multimeter and let us know what you get. Outside contact is negative and inside one is positive. Your battery should be a 3.7V. Less than ~ 2.7V may be below charging threshold. With the battery charger plugged into the camera try to measure the voltage on the contacts to make sure that your get a charging voltage. It should show even with the battery disconnected. If all that looks okay than the issue is somewhere on the power management circuitry on the main board. Let us know what you find so we can at least try to help you further

War diese Antwort hilfreich?

Bewertung 2

1 Kommentar:

The new battery is reading 4v, but the original one is reading 0v. The multimeter didn't read any voltage in the connections either. I don't know if there is a safety feature where it needs the battery, or if the connections need to be pressed in, as I had to use a couple of copper wires to reach them.

von

Einen Kommentar hinzufügen

You need new recharge able batteries

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

Lennon Horrocks wird auf ewig dankbar sein.
Seitenaufrufe:

Letzte 24 Stunden: 4

Letzte 7 Tage: 25

Letzte 30 Tage: 119

Insgesamt: 5,090