Zum Hauptinhalt wechseln

Repair information for the SteelSeries Arctis Pro wireless headphones. Released in March of 2018. Model number: 61743.

58 Fragen Alle anzeigen

Battery station not charging the battery

Whenever the battery is in the battery station it shows that it is fully charged but when I put the battery in the headset it doesn’t turn on as if the battery is empty.

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 4
1 Kommentar

im having the same problem. looking for a solution

von

Einen Kommentar hinzufügen

9 Antworten

Hilfreichste Antwort

I had the same problem as i just swapped my batteries out and it’s just died on me. Now the base station says ‘‘charged’’ for some reason. So, i quickly googled and someone said to try taking out all power to the base station for a moment, so i did for 30-60 seconds. Plugged it back in. Battery is now charging. It seems because of how long it remains on, the firmware glitches and fails to tell the base station to charge the batteries. Definitely doesn’t seem to be hardware related that’s causing it. Try turning off the power completely for 60 seconds and reconnecting it.

War diese Antwort hilfreich?

Bewertung 14

3 Kommentare:

This is what solved it for me. However! The battery only started charging again when it was inserted and I unplugged/replugged the base. When I took the battery out first, then unplugged, then replaced it the issue did not go away.

von

Thanks! This worked for me on my Arctivs Nova Pro Wireless headset. What confused me was that one of my two batteries would charge but not the other and they both came with the headphones. Also not very old like 6 months. Removed the battery from the base station, removed the power, and let sit for 60 seconds. Powered it back on, inserted the battery that was not charging and, wala, it's now charging. It was completely dead as well. Thank You!

von

Same issue on my Nova Pro Wireless where the dac would show full charge but the batteries are dead. Unplugged and replugged and it appears to be working again

von

Einen Kommentar hinzufügen

There might be many possibilities that your steel series Arctis Pro Wireless headphone won’t turn on.

  • Your headphone has some internal issue if there is no light on the headphone.
  • You're charging station has some fault, and it won’t charge the battery.
  • Last option battery is no more in working condition. Every battery has a life span. Maybe your battery is old.

To verify all the possibilities, buy a new battery and check with that.

War diese Antwort hilfreich?

Bewertung 1

1 Kommentar:

This is terrible advice. The person didn't state how long they'd had the device for you to conclude it's the batteries.

von

Einen Kommentar hinzufügen

Hi Micah,

I got the same problem.

When I put the battery in the charger I have to tweak it a little until the display show that its charging.

I guess its the contact inside the battery station that is the problem. Its really annoying that its not working properly.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

I had the same problem. I even disassembled the charger but i could not find the problem other than i thought it must be corrosion. I bought a fiberglass brush and cleaned the pogo pins on the charger and on the headset. Then I cleaned the contacts on the batteries.

That’s it. Now it’s working :D

Edit: You should be able to clean the pogo pins of the charger without disassembling it, through the battery slot.

War diese Antwort hilfreich?

Bewertung 0

4 Kommentare:

I highly recommend NOT doing what this person said to do, you could risk damaging it more. What i find worked for me just now is unplugging the device for 60 seconds and re-connecting it. The software on it seems dated so probably bugged/malfunctioned. Just needs a hard reset.

von

For me this does not work, as i turn off the power to the charger every night.

For me, it really was a corrosion problem. But if turning it off and on again works for you, great.

von

Hey Marcel, can I know how you opened it?

von

Powering it off didn't work for me either. I opened the terminal and inspected the prongs. Them, along with the battery terminals were dirty/corroded. I took some cotton swabs and some 91% isopropyl alcohol and cleaned them terminals on the battery, the pins, and the headset. I went thru 3 cotton swabs cleaning everything because of how black the cotton swabs would get. After they were clean, I cleaned them one more time and the cotton swabs were white after that. The coating on these terminals and battery are trash and after removing it with the alcohol, my problems are solved. Unfortunately, now I will most likely have to clean the batteries and terminals often to keep them clean. Don't touch the battery terminals or allow them to come in contact with anything other than the headset and the base. Less of a risk of them getting dirty.

von

Einen Kommentar hinzufügen

Yep I have the same problem I took a flashlight to look in the box and I saw that the three charging prongs inside were a bit bent to the right if you have this same problem wiggle it around to the opposite direction it won't fix it but it will charge :)

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

I had the problem that i placed the USB-C In the X-Box port and then you also get the same problems as you guys report.

also make sure it isnt installed on the X-Box setting. just to stat some easier to fix problems haha ^^7

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

My headphones are 3 days old and have this problem. I have first seen it not show the status of the battery in the headphones, but did show the status of the charging battery. Today its the opposite. Unplugging the base station from the USB port for 60 seconds fixes these problems. So for me cause the unit is brand new it has nothing to do with corroded battery contacts. Its a design problem hardware, firmware or both.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

A trick from being a radio operator. Use an eraser on the battery leads it worked for me with this same problem. other fixes that people had found was to disconnect the docking station for a minute and plug it in, some have firmware issues, which if those two steps don't work, i would suggest reverting to an older version if possible.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

I found a very simple solution on reddit that fixed mine. Depending on the issue, your battery may be so drained that the docking station isn't recognizing it.


Simply put the dead battery back in the headset, then plug the headset in via the USB-C port under the cover on the other side of the headset. I then turned the headset on, though that shouldn't matter. Give it a few minutes, then put the battery back in the charging dock. For me, it started charging again!

Other possible fixes:
- Restart the docking station.
- Clean the connectors on the battery with 70+% isopropyl alchohol

If all else fails, you can replace the battery with a standard np-45 battery.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

Micah Lee wird auf ewig dankbar sein.
Seitenaufrufe:

Letzte 24 Stunden: 50

Letzte 7 Tage: 318

Letzte 30 Tage: 1,423

Insgesamt: 32,456