Zum Hauptinhalt wechseln

The Dell Inspiron 17 7746 is a 17-inch screen notebook released in June of 2015. It is classified as a high-performance laptop.

1 Fragen Alle anzeigen

Dell Inspiron 7737 not charging, motherboard short?

Hi folks,

As above, I have a Dell Inspirion 7737 that detects when the charging cable is plugged in but will not charge any battery.

Failed attempts to fix so far;

  • Bought new dell battery
  • Flashed bios to latest A17
  • Windows fully updated
  • Uninstalled the AC drivers, rebooted with and without battery/AC etc
  • Tried Dells driver update tool, nothing of note
  • Bios showing AC adaptor as unknown (same for 2 different chargers) and battery shows as working normally

I think it’s possibly a motherboard fault as there looks to be a shorted capacitor (P 110) near the charge port area [see attached]. Any ideas if this could be the culprit?

Any advise would be much appreciated :)

JohnO

Block Image

Block Image

Block Image

Block Image

Block Image

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0
Einen Kommentar hinzufügen

1 Antwort

Hilfreichste Antwort

Hi @jollyboyjohn ,

Are you sure that it is a capacitor?

What is the designation next to it? I cannot make it out as it has been partly obscured. It shows ?5401 (see image below). Knowing the designation will tell you what type of component it is. Maybe you can clean it up and see what it says by gently wiping over the designation using a Q-Tip lightly moistened with clean water. Just don’t make the board too wet trying to clean it up.

If it says C5401 then it is a capacitor. If not then F=fuse, R= resistor, RN=resistor network, L= Inductor, D=Diode Q= transistor, just to name the more common designations found on a board

Have you measured it with a DMM’s Ohmmeter function to test if it is short circuit at all or even open circuit? You may have to remove it from the board in case there are alternate circuit paths around the component which may give false results when measuring it whilst it is still connected.

Block Image

(click on image to enlarge for better viewing).

Here’s a link to the motherboard schematics that may be of some help. Check that the board number of your board (printed on motherboard) matches the board number as shown in the link i.e. 12311-1-D0H50_HW_ULT_MB REV:A00 in case yours is different.

War diese Antwort hilfreich?

Bewertung 1

4 Kommentare:

Thanks for the reply @jayeff

Added additional photos to the question now

I’ll have to admit, I’m no very knowledgeable with using DMM’s for this sort of problem, sorry. All I could determine was 19.5v was getting to the motherboard and the battery socket.

From the schematic link, it appears this area is solely for the HDMI but this burnt one might be a fuse (F?). The only area I could see any corrosion was around a mounting hole near some power components but cleaned that off and the burnt area with IPA and still the same issue.

Also forgot to mention that the charging light wasn’t working before but after reassembly and all connections looking good, it went on for 2 seconds and they faded away. Won’t even work while laptop is off.

Unfortunately, I feel this is beyond my skills to repair and if it’s working fine with the charger in, I might only do more harm than good. I’ll just have to keep an eye out for a bargain used motherboard

Cheers though for the solid advice :D

von

@jollyboyjohn

F5401 is the 5V supply fuse for the HDMI so without the laptop turned on it should measure short circuit when tested with an Ohmmeter and not open circuit. Short circuit is the normal good test for a fuse that is not blown.

With the laptop turned on there should be 5V DC between either side of the fuse and an earth point on the motherboard e.g. screwhead.

If there is no 5V DC then there is a problem with the 5V DC supply on the motherboard.

This may also be the reason why it fails when on the battery only.

Check p.44-45 of the repair manual to see the AC/DC and the DC/DC circuits for the laptop

von

@jayeff

So that supply fuse does appear to have 5V DC when turned on and is also getting an ohm reading.

I also tried out the laptops old SSHD which then gave a start up message 'AC adaptor wattage and type cannot be determined' [added photo] so it may even be this that's preventing the battery from charging. The charging port itself appears flush and no debit stuck in about it.

If I discover a solution I'll be sure to update you.

Thanks again

von

@jollyboyjohn

Check p.44 of the schematic, lower right side "CHECK PM ADAPTER TYPE And setting adapter type" circuit

von

Einen Kommentar hinzufügen

Antwort hinzufügen

John Ogilvie wird auf ewig dankbar sein.
Seitenaufrufe:

Letzte 24 Stunden: 0

Letzte 7 Tage: 2

Letzte 30 Tage: 12

Insgesamt: 664