Type-C ports not working. Battery dead. Motherboard lights flashing...

XPS 13 9300 USB Type-C ports not working. Battery dead. Motherboard lights flashing when charger connected.


While living in North America In September of 2020 I ordered and received my new XPS 13 9300. I haven't been able to use it now for over two years.

I moved abroad and was using a stepdown converter to charge it which worked fine for a little while. Then I relocated again within the same country and suddenly the laptop would not charge even with the stepdown converter.

The charging cable light will come on and be steady when plugged in to an outlet (either in the stepdown converter or using an adapter in the wall) but when I connect it to the laptop the light on the charger starts blinking on and off steadily.

Before my battery depleated completely an error message came up breifly stating something about the system not being able to detect the charging system.

I removed the battery and tried to use the laptop with only the charger attached but the same thing happens. The lights on the motherboard flash as well when the charging cable light flashes.

I want to know if getting a new already charged battery might give me access to the laptop long enough to go in and reset the type-C usb port drivers since it seems that the different voltage in my current country of residence has confused the ports.

If anyone has any suggestions that do not involve replaceing the motherboard entirely (as that is not very possible for me at this time) I would really appreciate it.

I have seen other customers having similar port issues with the new XPS 13 9300 but I have yet to see any suggested fixes that the customer can do themselves.

I even discovered that there are "External battery chargers" available for older dell laptops so that the batteries can be charged seperate from the laptop itself but I have not been able to find one that is made to function with the new XPS 13 9300 battery.

Please help and thank you in advance.

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0
Einen Kommentar hinzufügen