Zum Hauptinhalt wechseln

Model A1419 / Ende 2013 / 3,2 und 3,4 GHz Core i5 oder 3,5 GHz Core i7 Prozessor, ID iMac14,2

344 Fragen Alle anzeigen

Problems after opening, cleaning and replacing processor

iMac was running fine. After opening, cleaning and replacing processor the iMac no longer boots up. Replaced the processor back to the original one, problem remained. Could this be the power supply? Diagnostic led 1 is on, the other ones do not light up anymore. I can hear the Hard disk spinning, USB ports deliver power. No boot sound heard, LCD screen remains black.

Beantwortet! Antwort anzeigen Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0
Einen Kommentar hinzufügen

1 Antwort

Gewählte Lösung

a common issue with these iMac's is getting the CPU chip to properly sit in the socket and sometimes the socket pins get messed up a bit.

The spring is a bit too strong and the RAM cowling gets in the way! Even I have problems!

You'll need to go back in and inspect the pins be very careful as they are easy to snap. Reshape the springs a bit to get some of the tension off. Don't go to far as the pressure is needed to hold things tight.

War diese Antwort hilfreich?

Bewertung 1

14 Kommentare:

Hello @danj thanks for your answer. Today I took the iMac back apart and saw that the original CPU was bend which indicates I at some point installed it wrong. When I checked for bend pins luckily non of them were bend or broken. I installed a new CPU being extra careful while installing the cooler not to move it and mess the CPU up again.

However when I reassembled everything and tried to boot it up the same things as before happened. I'm starting to think it's more of a power supply problem at this point because if I turn the iMac off and on again the number 1 LED blinks only once. I think this might be an indication that the power supply can't supply sufficient amount of power but I'm not sure. Also when the iMac is turned off I can hear a slight noise coming from the power supply and when turned on the noise is gone.

von

@robbem - What is the exact CPU you are trying to use? You are limited to the given Intel series this model used as the micro code held in the systems firmware will hold you back.

von

The new CPU that I’m trying to use is an Intel core i7-4771. The original CPU was an Intel core i5-4570.

von

@robbem - That’s a workable CPU, you shouldn’t have any issues with the power as the TDP is the same! Here’s the published Intel specs:

> i5-4570

> i7-4771

von

Yeah when the power supply is working correctly we shouldn’t have any issues as they have the same TDP. What do you think is the issue the power supply or the motherboard? And is there a way I can test this?

von

9 weitere Kommentare anzeigen

Einen Kommentar hinzufügen

Antwort hinzufügen

Robbe Meersman wird auf ewig dankbar sein.
Seitenaufrufe:

Letzte 24 Stunden: 0

Letzte 7 Tage: 0

Letzte 30 Tage: 3

Insgesamt: 146