Zum Hauptinhalt wechseln

Repariere deine Sachen

Recht auf Reparatur

Store

Model A1174 with 2 GHz Core Duo or Model A1207 with 2.16 or 2.33 GHz Core 2 Duo

280 Fragen Alle anzeigen

Why are there artifacts in my monitor?

My iMac has artifacts on the screen. Some lines are in it, which will change position, or not be there in an overlay of other windows. Any ideas what is going on, or what I can try? My best guess is the X1600 video core, or the video RAM is bad, but I would like to see what anyone else things. Thanks!

Beantwortet! Antwort anzeigen Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 2

Kommentare:

Did you connect the iMac to an external monitor ?

von

I will try that and report back.

von

I tried a 17" LCD with the DVI connection and it had similar issues. On my built in 20" monitor I get weird horizontal lines, but this did not happen on the 17". However, I get image tearing on both of them, and maybe it would just be a matter of time before I see a line issue on the 17". I ran it in extended desktop mode for about an hour.

von

Einen Kommentar hinzufügen

8 Antworten

Gewählte Lösung

If you hook it up to a external monitor and this happens there, it's the GPU. If it doesn't reproduce on the external, it's probably a bad panel.

In fact, it may even be the panel since the white Intel iMacs have display problems like the G5's did. Not to the same degree, but it did happen with them from time to time.

You can see how to replace the display here

iMac Intel 20" EMC 2105 and 2118 Display Replacement

War diese Antwort hilfreich?

Bewertung 1

Kommentare:

Are you talking connection from the core package to the logicboard?

von

This mac does not have a video card, the GPU is soldered directly to the logic board. Are you saying the BGA (ball grid array) is failing?

von

Einen Kommentar hinzufügen
Hilfreichste Antwort

I have thoroughly cleaned every aspect of this iMac. There is no dust left. I put new thermal paste on both the CPU and the GPU. Using SMC fan control I have increased the CPU fan speed (which also cools the GPU), and the artifacts have been significantly reduced. Not gone, but much better than before. Initially when I boot the computer or return from sleep mode there are several minutes before anything shows up. I think Apple can fix this issue, and it would not cost them a whole lot. If they made an optional flash utility for these computers (my research is showing this as a very common problem), which reduces the clock speed of the core, I am sure the issue would go away. Sure our graphics would be a bit slower, but that is a lot better than an $800 logic board replacement. I once had an iMac G4 800 which was not stable until I used it in the garage during the winter. I found the PLL control resistors on the logic board and cut the iMac down to 700MHz. It was perfectly stable after than even in high ambient heat.

War diese Antwort hilfreich?

Bewertung 2
Einen Kommentar hinzufügen

does it look like this. The last picture is the same I mac I removed the fancy desktop and put extra heat-sink on the video chip. I am waiting to see if it keeps it from locking up. I have replaced 3 screens and 2 mother boards but the pictures are very much the same. I feel it is the on board memory on the video chip is corrupt. If any one else has any ideas let me no.

thanks

War diese Antwort hilfreich?

Bewertung 1
Einen Kommentar hinzufügen

Bildinhalt anzeigen:

Block Image

Block Image

Block Image

Block Image

Block Image

War diese Antwort hilfreich?

Bewertung 1
Einen Kommentar hinzufügen

My 20" white Intel iMac has the same problem. It's definitely temperature related and it doesn't appear if I boot up in safe mode so I suspect it has something to do with the graphics acceleration, which is disabled in safe mode. So I'm in agreement with those who believe it's the GPU that's faulty. If Dylan can run Windows XP from Bootcamp without seeing the fault, maybe XP isn't using graphics acceleration. Is there a way of starting Mac OS X in normal mode but without the graphics acceleration? Suppose I temporarily (or permanently) moved the relevant .kext file?

War diese Antwort hilfreich?

Bewertung 1

Kommentare:

According to System Profiler there appear to be four ATI-related kexts that are loaded on a normal start-up: ATI1600Controller.kext, ATIFramebuffer.kext, ATIRadeonX1000.kext and ATISupport.kext. Of these, three are also loaded during a reboot into safe mode. The one that is not loaded is ATIRadeonX1000.kext so, in safe mode and logged into an administrator account, I opened Terminal and renamed the folder called ATIRadeonX1000.kext. I actually called it ATIRadeonX1000.kext.disabled and I can always reinstate it if necessary. There's probably a cleaner way of stopping it being loaded but I haven't found it yet. I restarted the iMac in normal mode, checked that the kext was not loaded and in four hours of normal use it hasn't shown the problem once. I guess I've lost some graphics capability but I'm not sure quite what as it seems little different. In any case it's actually usable now, which is much preferable to how it was.

von

Incidentally, I realise this is an old thread and these old white iMacs are stuck with a maximum of 3 GB of RAM and Lion as the OS. However, when they work they are nice machines and are quite capable of most of the things a home user wants to do. I've actually stayed with Snow Leopard on mine as I think Lion (the latest it will run) was a particularly poor release of Mac OS X. So hopefully someone might find this still useful.

von

John Morley got it ! My son's old 20" intel iMac had the video artifact described. Booting without extensions didn't show the troubles, disabling the ATIRadeonX1000.kext acceleration extension did the trick . This old iMac is now still alive and well (although a little bit outdated by a software point of view).

Nevertheless, thanks John for being so helpful !

von

Einen Kommentar hinzufügen

I have the same problem with the EMC 2105. How do you know if its the GPU or the memory chips? If you reflow the chips how long will it last? I know someone with the machines to remove the chips and resolder them but they want $200 and he says it may not last more that 3 months. Does anyone know more about this? Thanks

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

A comon isue with this model however I find it odd that it never happens while using bootcamp Win XP. no video problems at all.If it was a hardware isue then the problenm should remain regardless of what OS your running., IMO.

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

I'm with Gord...I think it's that ATI had a bad batch of X1600's and it's corrupt or bad onboard video card memory. It could also be bad solder joints, thermal paste, etc.. but the damage from the first time it happened has likely caused irreversible damage to the involved components.

I'm running SMC fan Control and it helps, but you can forget about playing video games. Not for very long at least. If the vid card gets too taxed, the screen will either go black (tho the OS is still running), or the machine will just freeze up. It's all due to the faulty vid card, I'm convinced. I just use it for every day applications, and do nothing that I want to do on the machine. I'm hoping for a new iMac soon, and doubtfully will be able to get any money for this machine on eBay. Parts? The parts everyone wants is the part that is bad on my machine! Plus, my screen has some light scratches on it from my toddler son messing with it.

When I get a new one, I'll probably put a bullseye on the machine and squeeze off a few rounds in the back yard. That would be worth the $50 I'd get on ebay for it.

And for the record... it's the ONLY Mac of MANY that I've ever had a problem with.

Jason

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

Eric Drust wird auf ewig dankbar sein.
Statistik anzeigen:

Letzten 24 Stunden: 2

Letzten 7 Tage: 9

Letzten 30 Tage: 34

Insgesamt: 7,592