MBP Mid 2014 Not Booting, Possibly a Logic Board Issue

Hey there,

I posted here about 2 years ago now looking for advice on my 2014 MBP. At the time it had just hard bricked, so I swapped the logic board with a refurb one I got off ebay and did a clean install of the OS. This was April 2019 and it was working fine up until last week. Also just before it bricked I had replaced the battery, and the new one worked fine until recently.

So what happened is it just up and crashed on me one day when I was using it. If I press the power button I get the startup chime, it goes to the default login screen, I have just enough time to put in my password, and then the screen goes blank but you can tell its still on. I can hold the power button down to turn it off and try again but the next time all I get is the screen turn on and half of the chime, and once more I just get the screen on. If I leave it for awhile the process seems to reset, I can start it up and get the chime and get to the login page before it blanks again. This all happens in the course of about 10 seconds. For awhile as well the fan would turn on every time I hit the power button, then turn off if I held it down, but it stopped doing that now.

I had been seeing a ‘replace battery’ warning for awhile now so I got a new one but that didn’t seem to change anything. The light on the magsafe was orange when I first got it and then changed to green after awhile so it seems like the charger and the power connection in the laptop are fine.

I have an enclosure for the SSD which I connected to another laptop to confirm if it still worked. I ran first aid in disk utility which returned no errors and all my files seemed to be in the right place.

I did try connecting it to my tv with the HDMI port thinking that maybe there was an error with the display, but after messing with it for a bit I could never get it to show anything.

I reset the SMC, tried booting in recovery mode, and another diagnostic mode which displayed the startup sequence, but the same thing happens after about 5-10 seconds. With all the above info I’m assuming this is something wrong with the logic board somewhere, but I don’t where to go from here.

Any other avenues I could explore? Any ideas as to why this seems to keep happening to my logic boards? Currently I’m trying to decide if I want to drop $5-600 on another logic board or if I wanna bite the bullet and buy a newer model.

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 1

5 Kommentare:

To be clear when you boot up you are seeing a fleeting screen image?


Yep. Most times I get at least the Apple logo but sometimes the screen just turns on but doesn’t display anything.


Do you have access to a second system which you can use to test out your systems battery? It will need to be a system in the same series. I'm thinking you have a bad battery here.

If you can test it, let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Bilder zu einer vorhandenen Frage hinzufügen


Sorry, guess I wasn't clear in my post. I already tried swapping a new battery but I still have the same issue.


@geoffgrauer - No I got that ;-}

Just because its a 'new' battery doesn't mean its a good battery, or if the battery is even charged. Using CoconutBattery from another working system with your systems battery we can discover what its state is.


Einen Kommentar hinzufügen