Zum Hauptinhalt wechseln

Modell A1369, 1.6, 1.7, oder 1.8 GHz Prozessor, 64, 128 oder 256 GB Flash Speicher.

328 Fragen Alle anzeigen

Internal Keyboard shows up on system profiler but does not function

Hoping someone can solve this mystery for me:

I just replaced the top case on my son’s MacBook Air. After reassembly, internal keyboard and power button have zero response, but trackpad works fine.

Checked the keyboard cable - it’s seated properly. I have tried two different top cases, one A stock, one B. Same result with both.

Trackpad flex cable looked fine, but changed it just to be sure. Again, no keyboard response, trackpad is fine.

Boots when power cord plugged in, but I can’t reset SMC since the keys are not communicating.

Keyboard shows up in System Profiler, so I’m thinking I can rule out a logic board issue…??

Deleted .plist files as instructed in another forum.

Pref Pane in system info: Version 14.0, visible, 64-bit

It’s an old machine, but it’s in good shape and perfect for a teen, so I’d like to keep it working. but I’m at a loss for what to do next.

Any insights or ideas would be tremendously appreciated.


MacBook Air 13” Mid 2011

High Sierra 10.13.6.

Block Image

Block Image

Block Image

Block Image

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0

4 Kommentare:

Sadly its starting to look like the cable its self has failed.

This is a wacky cable! Its really two units shaped in a Y one arm is from the trackpad and the other to the connector the leg side is where the two are soldered together. I never understood why Apple did this as flipping the connector around would have been a better design so the cable just slides in.

Other than replacing the keyboard it's self thats the only thing I can think of. Did you get the correct uppercase for your system? There is a difference in some of the models.

You've stated the trackpad is working so that tells us the USB signals from the trackpad is getting through and as you replaced the trackpad. Did you run the trackpad firmware updater? To see if that was the issue. As thats the only other thing I can think of.


Did not run trackpad firmware update.

Not sure where to find it. It'll try it. Thanks...


Thanks. Tried it. Says not supported on my system. running high Sierra, updated to the last supported version for an A1369 machine.


Einen Kommentar hinzufügen

1 Antwort

What happens when you open up the Keyboard viewer and hit the keys does the viewer key change in turn?

Open Preferences under the Keyboard section check - Show keyboard and emoji viewers in menu bar

Also within the Keyboard control panel what do you have selected in the Input Sources? You should have U.S. selected.

Update (11/15/2021)

@kingofmac - Hoping it was a simple issue.

Lets inspect the keyboard connection on the trackpad. Can you take a nice clear & sharp picture of the connector so we can see it at it is now as well as after disconnecting the cables I'm thinking the trackpad keyboard input has failed Bilder zu einer vorhandenen Frage hinzufügen

Block Image

If it has you’ll need a new trackpad

War diese Antwort hilfreich?

Bewertung 0

3 Kommentare:

Keys on viewer show no corresponding response to keystrokes.

Show keyboard and emoji viewers - Check.

Input source: US - Check.

Meaning, was checked. I checked, and the settings you said to check were checked. I was really hoping they weren’t, but they were.

Thanks, though.


i'll send pics. But it is a new trackpad.


@kingofmac - Time to visit someone local to you to check things out. Where are you located country and nearest major city, maybe we can aim you to someone.


Einen Kommentar hinzufügen

Antwort hinzufügen

Adam Goldstein wird auf ewig dankbar sein.

Letzte 24 Stunden: 0

Letzte 7 Tage: 1

Letzte 30 Tage: 14

Insgesamt: 87