Zum Hauptinhalt wechseln

Model A1224 / Mitte 2007 und Anfang 2008 / 2, 2.4, oder 2.66 GHz Core 2 Duo Prozessor

537 Fragen Alle anzeigen

Screen blank, fans ramp up to max speed when turning on.

More information:

Some time ago I tried to repair my dad’s 2007 iMac (20” I think) but it didn’t go so well. My goal was to replace the SATA cable for the hard drive and upgrade the CPU. I installed the CPU with success, but the cable wouldn’t fit in. That’s not what I’m worried abut right now, though. When trying to power it on after re-assembly, the fans ramp up to max speed, and the screen is blank. I’ve tried resetting th SMC and all that stuff, but to no avail. I really want to get this machine working again, any solutions?

Edit 1: 1/13/2022

The iMac now turns on and is fully functional. The problem was a disconnected cable on the back of the motherboard, hence me not noticing it on the first look-through.

Edit 2: 1/14/2022

It was the CPU Heatsink heat sensor for anyone that cares.

Beantwortet! Antwort anzeigen Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 0
Einen Kommentar hinzufügen

1 Antwort

Gewählte Lösung

SMC thinks you have a problem as such it will ramp up the fam to make sure the system doesn’t over heat. You likely forgot to connect one of the cables to the logic board or something is damaged.

So I would review this guide to make sure everything is connected up properly and if you see something thats damages or just doesn’t look good take a nice clear picture so you can post it here for us to see iMac Intel 20" EMC 2133 and 2210 Logic Board Replacement and here’s how to post a picture in your question Bilder zu einer vorhandenen Frage hinzufügen

iMac Intel 20" EMC 2133 and 2210 Logic Board Bild

Anleitung

iMac Intel 20" EMC 2133 and 2210 Logic Board Replacement

Schwierigkeitsgrad:

Schwierig

1 - 2 hours

iFixit Bild

Anleitung

Bilder zu einer vorhandenen Frage hinzufügen

Schwierigkeitsgrad:

Sehr einfach

2 - 5 minutes

War diese Antwort hilfreich?

Bewertung 1

5 Kommentare:

Ok, thanks. I'll go check it all out now and get back to you.

von

So far it seems like it's the logic board or GPU- LED #4 is not lit up and the flashlight test failed. External monitor doesn't work either.

von

@shrek420 =- Sorry ;-{ Finding the needed MXM GPU card is getting hard and you might end up having to get a few as you'll likely get a bad one.

von

@danj Dang. Any way I could test the parts with a multimeter to figure out what the problem is before buying anything?

von

@shrek420 - If the #4 LED is not lit, the GPU logic has failed. You will need access to a set of schematics and board views to guide you.

von

Einen Kommentar hinzufügen

Antwort hinzufügen

Zachary Rushworth wird auf ewig dankbar sein.
Seitenaufrufe:

Letzten 24 Stunden: 0

Letzten 7 Tage: 0

Letzten 30 Tage: 0

Insgesamt: 36