Zum Hauptinhalt wechseln

Repariere deine Sachen

Recht auf Reparatur

Werkzeug & Ersatzteile

Der Mac Pro (Anfang 2009) kam im März 2009 auf den Markt. Er führte erstmals die Nehalem Architektur von Intel in die professionelle Apple Desktop Reihe ein, und verfügt über ein leicht neu konzipiertes Inneres, das auch bei den 2010 und 2012 CPU Updates beibehalten wurde.

86 Fragen Alle anzeigen

2009 Mac Pro won't boot with new RX 580

Hi, Thanks in advance for any help. I have a 2009 Mac Pro -> 5,1 and upgrade CPUs running OS X 10.13.6. I wanted to upgrade my video card. I have tried the Vega 56 and now the Sapphire Nitro RX 580. Using both Aux power ports. These were my results:

When I tried the Vega, it booted fine, BUT NO VIDEO. Thinking it may be a bad card I returned for a replacement and am waiting on that. Resigned to save for a PC build.

So I then purchased the RX 580 (nice blue card)! When I installed the card I get nothing. Just a click from the PSU and that’s it.

So I put my stock GT 120 card back in and everything is fine. Boots just fine. I tried the RX 580 again in the other x16 slot. “Click” was all I got. GT 120 back in boots fine.

I almost think it is a PSU issue; that maybe it is not putting out the power needed. The voltages on the aux ports is fine, but I have no way to test with a calibrated load to see if indeed the PSU is putting out the power it is supposed to.

Any thoughts? Am I doing something wrong or forget to do something?

Diese Frage beantworten Ich habe das gleiche Problem

Ist dies eine gute Frage?

Bewertung 3

Kommentare:

What method did you use to flash your machine to 5,1?

What CPUs are you running?

von

mayer, I used the the tool at the netkas forum and the firmware from Apple. Both links can be found in the notes of this video https://www.youtube.com/watch?v=3Z2ZSie7...

I am running a pair of X5680 SLBV5 3.33GHZ.

-mark

von

Anyone have any ideas?

von

Could it be a driver issue?

Have you tried booting it with the new card and then use the screen sharing function on another computer?

von

The drivers themselves are included with OSX 10.13. But it won't boot period with the RX 580. I guess I could try again with the Vega 56 card.

von

3 weitere Kommentare anzeigen

Einen Kommentar hinzufügen

2 Antworten

Mark, I figured one of the greybeards would have cranked out an answer by now, but I'll throw in a few suggestions:

- Reset the SMC + PRAM (Page 26-27)

- Follow the Apple Technician Guide for "No Video" (Page 49)

For the tech guide, go here and scroll down to the bottom, you’ll see the PDF: Mac Pro 2009-2012 Repair

Sure, it could be a PSU issue, but I sincerely doubt it since it seems like the RX 580 is the go-to GPU for Mac Towers ever since Mojave came out, since it “requires a graphics card that supports Metal” according to this article. Unless, of course, the actual PSU is failing. Though I would try every possible alternative before pointing the finger towards the PSU if the computer boots normally with the stock GPU.

Something I also found was this YT Vid that says “If you'd like to use your Mac compatible graphics card alongside your RX 580 for boot loader support, you can always use power from a SATA port from the hard drive bays convert that into a 6 pin with a SATA to 6 pin adapter.” I mean, it’s not ideal, but worst case you could try that…

I also saw some valuable info on this site. Not sure the punchline here, but it’s a Friday night and I ain’t got time to read that but you probably do. Check it out here.

The last discussion I saw that was helpful was this one, which also links to another discussion with more insight into the issue.

Let me know if this helps, I’d gladly like to know what the solution its. Feel free to contact me through my email on my contact card too.

-Alex

War diese Antwort hilfreich?

Bewertung 0

Kommentare:

Thanks, Alex, I will go through each of your suggestions and report back. Maybe we can get this solved yet, and hopefully provide help for someone else

-mark

von

Sounds good, Mark. After looking, seems like the main options are:

1. Run the stock GPU alongside the RX

2. Try using the "Mac Compatible" Sapphire Pulse RX 580 (Unless that's the one you have)

3. Buy one of the "flashed" GPUs from website mentioned in the Apple forum.

Let me know if you find anything. I'm interested in seeing the solution because I'm doing a 4,1 -> 5,1 beast this summer hopefully, I was planning on using a Vega or the 580 so, would be good to know.

-A

von

Einen Kommentar hinzufügen

Well I think I just figured out the issues with that card I have the ASUS rx580 rog 8gb and it wasn’t working on boot up but once I put it in recover the gpu started working so more than likely you will have to reinstall your OS X or just put it as if you was to boot into the recover drive and see what happens and I have a 2008 Mac Pro 3,1

War diese Antwort hilfreich?

Bewertung 0
Einen Kommentar hinzufügen

Antwort hinzufügen

Mark Symms wird auf ewig dankbar sein.
Statistik anzeigen:

Letzten 24 Stunden: 8

Letzten 7 Tage: 45

Letzten 30 Tage: 273

Insgesamt: 2,535